PDA

View Full Version : Trailer position light problem


vroom
07-21-2011, 02:22 PM
I have a light problem with my trailer. Backup light are ok, falsher light ok, but no position light!

Trailer is ok because they work on my friend jeep! I've checked the car fuses box, everything ok! I even had the dealer check my wiring plug and they said everything looks good!

Any idea why these light aren't working?

thanks

TxsRiverRat
07-21-2011, 02:41 PM
I have a light problem with my trailer. Backup light are ok, falsher light ok, but no position light!

Trailer is ok because they work on my friend jeep! I've checked the car fuses box, everything ok! I even had the dealer check my wiring plug and they said everything looks good!

Any idea why these light aren't working?

thanks

Try a new pigtail and see if it isnt a ground wire issue

KnoxX2
07-21-2011, 02:48 PM
Same problem! Found that the ground was bad. Check all the ground wires on the lights.

vroom
07-21-2011, 03:46 PM
Thanks guys,

Is the ground trought the frame? or in the wiring? I tought the ground was in the 7 pin plug (i.e. in the wiring)...

I think checking each light is useless, because the work on another car...

TxsRiverRat
07-21-2011, 03:48 PM
Thanks guys,

Is the ground trought the frame? or in the wiring? I tought the ground was in the 7 pin plug (i.e. in the wiring)...

I think checking each light is useless, because the work on another car...

The ground is through the wiring at the tongue... Go buy a new pigtail (about $8) and see if that fixes it.