PDA

View Full Version : B.I.G Problems


vols1
07-19-2011, 11:07 PM
I went out on my 2011 X2 tonight and my B.I.G screen is off. The screen looks the same as when the boat is off. The boat runs fine its just that nothing works on the B.I.G. Has anyone else had this problem ?

Stevensxstarguy
07-21-2011, 02:04 AM
I went out on my 2011 X2 tonight and my B.I.G screen is off. The screen looks the same as when the boat is off. The boat runs fine its just that nothing works on the B.I.G. Has anyone else had this problem ?
I had the same thing happen on my 2010 xstar. We turned of and on the ignition a number of times (didn't work) and then turned the key quickly to the right hard and it worked great. We continued lastbweek to start my star the same way (to the right fast and hard) and seemed to work fine. Hope this works. Good luck

MariStar-Man
07-21-2011, 02:57 AM
I don't know if this would help because we don't have the BIG on our V-210, but maybe a bang it around a bit like an old coke machine that didn't dispense the sody-pop...


.

.

I'm sorry, it's just that if it was mine I'd of already threw in the lake. I don't have patience for electronics that don't do what they are supposed to do every time they are supposed to do it. And if it's an intermittent problem, it's one more reason to get a brand new one...

my .002

FourFourty
07-21-2011, 09:12 AM
Do your gauges and tabs work?? I had something similar happen when my boat (11' X25) was brand new.... Except, I lost my gauges and tab controls also. I looked at the Viper module and it turned out that the usb plug was broken by the monkey that put it together at the factory. Because of that, the module connector was bouncing around inside the module and causing intermittent problems. New viper module cured it.

If you have gauges, check the video cable from the viper module to the BIG. and make sure it didnt get unplugged.

vols1
07-21-2011, 11:31 PM
It turned out to be a bad viper module as well. My dealer CBC replaced it in a couple of hours. It pays to have a professional dealer that still values customer service. I went out tonight for a test run and everything worked perfect. Thanks to Randy and Stacey at CBC they went above and beyond anyones expectations to get me back on the water.

Thrall
07-22-2011, 01:52 AM
As they should when you plop down 6 figures for a 21' boat.
Glad you got it fixed, glad I don't have that stuff on my boat!:)