PDA

View Full Version : looking for an 81 stars and stripes electric schematic


1redTA
07-11-2011, 06:11 PM
I am having some starting solenoid issues with my 81 S S and could use an electrical schematic. Thanks, Art

ps I have used the search function and maybe the right person hasnt seen the post in the electrical section

Slinkyredfoot
07-11-2011, 09:24 PM
From my 79 351 PC engine manual, should be very similar. Best I got and good luck.

1redTA
07-11-2011, 09:31 PM
Thanks! the diagram for the harness with the pin out should really help me out

thatsmrmastercraft
07-12-2011, 12:35 AM
You guys and your new boats:rolleyes::D

Nice post Slinky:cool:

Slinkyredfoot
07-12-2011, 07:19 PM
Thanks, don't know much about the new ones that I ride around and try to surf behind these days, but I know the old ones like the back of my right hand. Glad to oblige

03geetee
07-12-2011, 10:58 PM
Old boats bring all the boys to the yard!

JTR

east tx skier
07-12-2011, 11:05 PM
Here's the PCM diagram.

http://www.mastercraft.com/teamtalk/attachment.php?attachmentid=43269&stc=1&d=1230475845

1redTA
07-13-2011, 02:41 PM
Here's the PCM diagram.

Thanks east tx! hopefully now I can correct the years of misuse

1redTA
07-13-2011, 10:32 PM
well, I wired up my boat like East TX's PCM wiring diagram. Put a new ARCO solenoid in and when I cranked the engine it kept turning over, had to disconnect the positive cable to get it stop.

Then I pulled the main battery lead to the starter and inspected it.
It was a clear jacket 0 gauge wire, the strands of the wire looked kinda of corroded and it had some spots in it that were blackish in color. I tested it for ohms and it read 0 although the voltage was kinda spoty when I moved the wire sometimes 3V sometimes over 12.X. I am going to replace it and start over from there

thatsmrmastercraft
07-14-2011, 12:27 AM
well, I wired up my boat like East TX's PCM wiring diagram. Put a new ARCO solenoid in and when I cranked the engine it kept turning over, had to disconnect the positive cable to get it stop.

Then I pulled the main battery lead to the starter and inspected it.
It was a clear jacket 0 gauge wire, the strands of the wire looked kinda of corroded and it had some spots in it that were blackish in color. I tested it for ohms and it read 0 although the voltage was kinda spoty when I moved the wire sometimes 3V sometimes over 12.X. I am going to replace it and start over from there

You probably fried your solenoid with all the corrosion.

east tx skier
07-14-2011, 12:48 AM
well, I wired up my boat like East TX's PCM wiring diagram....

Not mine. I think that may be the one TRBenj posted some time ago.

1redTA
07-18-2011, 07:49 PM
Thanks Guys!
I got the boat out today for a little fun. The new lead wire from the battery to the solenoid did the trick. I also stopped in ARCO and talked to one of the guys for a little while and he recommended to run a grounding wire from the solenoid to the block.