PDA

View Full Version : Boat died need some help 2006 x1


durcanchris
07-02-2011, 03:35 PM
My boat turned off today in the middle of my set and wont turn back on. The ballast switches work but no buttons on the dash work, the gauges wont come on and the boat wont crank at all. Steps I have already taken are resetting the ignition fuse and all the other fuses under the steering wheel, checked all battery terminals, checked the fuse on the EMC on the engine and all the other basics. Any suggestions? boat is an 06 x1

THANKS!!

ttu
07-02-2011, 04:19 PM
how about the reset button (or what ever it's called). located on the port side of the engine towards the front of your boat. here is a pic i took of mine.

durcanchris
07-02-2011, 04:20 PM
Yea,,,tried to push it in.....nothing. It wont push in at all.

Chief
07-02-2011, 04:24 PM
Check the wiring harness behind the dash. You won't believe how much stuff is back there. Check for any loose connections. Usually isn't enough strain relief on some of the major connections.

Will the engine turn over?

durcanchris
07-02-2011, 04:28 PM
Nope wont turn over, nothing happens when you turn the key in either position. The ballast switches still work, but nothing on the dash... bilige, aux lights etc do not work.

durcanchris
07-02-2011, 04:31 PM
I will try the wiring harness and let you know. Is there anything else you can think of to check? I have to drive to the storage work on it and want to have a couple of options when I get there. Thanks

vision
07-02-2011, 05:35 PM
Gear shifter in neutral? I never remember if the neutral lock out switch also prevents power to the gauges.

ttu
07-02-2011, 05:41 PM
Nope wont turn over, nothing happens when you turn the key in either position. The ballast switches still work, but nothing on the dash... bilige, aux lights etc do not work.

well you tried what i gave you advise. seems identical to what my issue was.

here is my link.

http://www.mastercraft.com/teamtalk/showthread.php?t=40709

durcanchris
07-02-2011, 06:59 PM
I will try all the idea that they mentioned. Where was your bilge switch located? On my boat only my 3 ballast switches below the throttle work. No switches on the dash work.

TOO-TALL
07-02-2011, 07:51 PM
There's a accesery(sp) breaker located by the battery.At least on my boat it is.

Reset the breaker by the battery.
Mine went out a few years ago.And none of the dash gauges worked.

durcanchris
07-03-2011, 10:28 AM
Anymore suggestions? I am going to the boat this morning