View Full Version : No power, no nuthin.

06-29-2011, 06:48 PM
Went to start the boat. Turned the key and heard the standard click click click, turned all the way to start.

Sounded like a dead battery kinda, but maybe more like a little sizzle click sizzle click. I turned the key back to off to retry, and I've got zero.

No fuel pump sound, no perfect pass or instrument gauges...anything on the circuit that has to have the key on, I've got nothing.

The blower works, the ballast pumps work, lights work.

I messed with the kill switch (which I never use or touch) and got no change.

I checked all the breakers under the dash. Nothing.

The breaker next to the battery does not seem to have popped either.

Help. The dealer says "i'don kno....."

06-29-2011, 07:01 PM
Start by checking/cleaning all the heavy cables from the battery to the starter and back to the battery. All connections should be clean and tight, including both ends of the ground cable.

06-29-2011, 07:07 PM
Pulled all the battery cables, flipped the batteries, put em on a charger (good charge).

06-29-2011, 07:27 PM
Bypassed the 40 amp breaker by the batteries, nope.

06-30-2011, 02:27 AM
That breaker has nothing to do with the starter. Might be a good idea to remove the starter motor and have it tested at this point.

06-30-2011, 03:10 PM
Check the starter solenoid?

east tx skier
06-30-2011, 03:14 PM
How does your ignition wiring look under the dash. I had a wire come lose from the back of the ignition/key and it was a pretty frustrating couple of hours before I figured it out.

06-30-2011, 04:00 PM
I am sure it is not the cause since you initially had a response. But make sure the gear shifter is in neutral. I can never remember if the gauges stay dead with the neutral lock out switch?

06-30-2011, 04:28 PM
Ok. Tightened the wires going into the starter and *whalaa*. Situation resolved.

And seriously, tightened. They were there and attached. Couple threads on the post.