PDA

View Full Version : exhaust Baffle snaps out of pipe!


Grantx15
06-23-2011, 07:20 AM
http://mastercraft.com/teamtalk/picture.php?albumid=411&pictureid=3239:mad: http://mastercraft.com/teamtalk/picture.php?albumid=411&pictureid=3240Not a happy boater.

out on the river on a Glassy day yesterday, friend of mine noticed the boat seemed to be louder than usual. to me it was a yes and no. i couldnt really tell at idle. but to my suprise when i pulled the boat out of the water last night this is what i had to look at. ( see the two attached pictures...) my exhaust baffle is GONE! it ripped out of the exhaust pipe. you can see the metal sheared around the inside of the pipe an the spots where the baffle was welded tack welded in. i dont see how it could rip out, its location is deap in the pipe, nothing can hit it or wrap around it. but somehow its gone.
my Questions...
has any one ever had this happen??
is it ok to drive the boat still with out the baffle?
any ideas on replacing that part?? costs?

and thoughts would be great. thanks.

Tlxstar
06-23-2011, 08:29 PM
Had the same thing happen on my 2007 X-Star. Noticed it the same way -- from the louder exhaust note. Boat ran fine for a day or two and then I had a check engine warning come on. Only thing the dealer could come up with was the exhaust baffle being missing, but no confirmation that this is what triggered the alarm (boat went into limp mode, btw). Replaced it and all is fine. Was done under warranty so I can't give you any guess on the cost. Good luck!

Grantx15
06-23-2011, 09:55 PM
hmm yeah i was told they had issues with this.
so i spoke to jim at bay area watersports in tampa (mastercraft dealer) he let me know i should replace both not just he one...... and its about a 4 hour labor job. you have to heat up the pipes and all kinds of other fun stuff, he is having some one call me friday he doesnt think it will be covered on warranty for mine.
i heard from a guy at mc dealer in NC he said they are about $150-225 each... for through hull pipe with baffle.

im about to rip out the other one and just have a loud MC haha.
kidding.

jimmies1
06-23-2011, 10:34 PM
Had the exact same thing happen to my 07 Xstar. Boat did sound awesome without the baffles...

Grantx15
06-24-2011, 07:22 AM
wow so it seems like 2007 wasnt a great year for Mc's Baffles.
im only missing one baffle right now, but it doesn sound nice. i would just rip the other one out if i wasnt so worried about water flowing back up into the engine.... what do you think?

jimmies1
06-24-2011, 07:45 AM
I ran mine for a year without baffles and never had an issue. Very unlikely you would get water that far up in there to make it to the engine

Stars & Stripes
06-24-2011, 09:02 AM
I had one fall off of my 08 X45 last week.

Grantx15
07-07-2011, 11:17 AM
any one that has had their Baffle come out have you ever had a ECU code come up flashing and shutting down your guagues and perfect pass??
im not sure if this is happening due to the baffle bing gone or if its just more fun problems my boat is having.

ttu
07-07-2011, 11:23 AM
the baffle came out of my 07 x2 about a month after i bought it. dealer replaced and to date have had no issues. did not get any codes and ran it for a couple months with no issues.

cbryan70
07-07-2011, 01:23 PM
do you lose just the tip? His looks like it blew everything out in the exaust hose as well.

jimmies1
07-07-2011, 02:34 PM
Mine blew out everything. I removed the inside out of the other one also and the boat ran fine and sounded awesome. Never had any codes or problems

davidstan
07-07-2011, 03:22 PM
there was a change for sure between o7 and 08. my next door neighbor has an mcx 07 like the one pictured with the tips and his boat is quite, my 08 just has flaps, no tips and the baffle further up the pipe. My 08 is on the loud side and def louder than his 07.

Grantx15
07-08-2011, 08:19 AM
Yeah, everything blew out of mine, not just the tip. Alright so since no one else had codes or ECU issues when you lost your baffles I guess it is safe to assume that my ECU issues are just another problem im having.

nkknutson
08-01-2011, 04:48 PM
Same thing happened to me this weekend and this is after I got the fuel pumped replaced....it has been a rough July. So is the consensus to run without the exhaust baffle and get it fixed at the end of the season or should I take it in and get it done now?

If people are taking theirs to get fixed are they getting both fixed? I have 2007 X-1 and from what I have read they don't make the one's I have any more. So to match I would have to rip out the one that works to make it match my port side "the new one".

Thrall
08-01-2011, 06:16 PM
If any of you are thinking about fixing this yourself, check out Rex Marine.
http://www.rexmar.com/page230.html
They have silencers as well.
I like the look of the newer boats with the chrome exhaust (since mine spends most of it's time on the trailer.:(), but after seeing hte problem with the MC exhaust tips I've decided to leave my good old fashioned exhaust alone.

bturner2
08-01-2011, 09:20 PM
Anyone actually changed these out themselves? I'm just wondering how bad they'd be to replace.

dgaugler
08-01-2011, 11:20 PM
My muffler just had a piece of the inner lining come out. Plugged the exhaust on the port side almost completely. The baffle is still in place but I'm worried about further failure. Not sure if I should replace them both or not. '96 Maristar 200 VRS

rrskier
09-22-2011, 12:44 AM
Tonight while skiing I noticed my 07 X7 sounded louder than normal. Back at the dock I stuck my hand up the exhaust outlet and no baffle on starboard. About six months after the boat went out of warranty I noticed the baffle and inner plate were loose. I contacted my dealer who asked the Territory Service Manager for a Policy Adjustment. We were refused, even though this is a known problem with 07 boats. I had the baffle spot welded in place and it held until tonight.
Anyone out there replace both outlets on an 07 so you would have one good assemble I could buy?

rrskier
10-10-2011, 07:57 PM
Anyone out there have a non blown out baffle off a 2007? I hear its quite a job to break loose the 3M sealant from the transom, a job I only want to do once.