PDA

View Full Version : Center Ballast filling by itself.


skongolf
06-17-2011, 09:28 PM
Took the boat out today and after about an hour of driving I lifted the ski locker hatch to find the center ballast was full and I had not turned it on all day. Drained it all out and took a couple hour break. After another hour or so of running it had filled up again. The rear tanks were empty, but the center keeps self filling. Just curious what might cause this. I know I have seen on other forums this has happened, but wanted to find out specifics for my 01 X30. Thanks for any input.

G-Star
06-17-2011, 09:34 PM
Replace your impellers. When they get old/worn they let water out if you're sitting, and in if you're moving and forcing water into the thru-hull intake.

Buy the green impellers. They're supposed to be the best.

skongolf
06-17-2011, 10:44 PM
Ok, thanks for the info. I am not sure if the boat has original pumps or not. The guy we bought it from sounded like he swapped out the original pumps with cartridge style bilge pumps. Where wod the original pumps be located? Pics would also be helpful if anyone has them. Thanks again!

hragsarkissian
06-18-2011, 05:21 AM
i have the same problem...sometimes...with the center one, just ordered a green impeller and will replace it when it gets here...It shouldn't be a problem if the boat remains in the water while i replace it right?

73blue
06-18-2011, 08:13 AM
Ok, thanks for the info. I am not sure if the boat has original pumps or not. The guy we bought it from sounded like he swapped out the original pumps with cartridge style bilge pumps. Where wod the original pumps be located? Pics would also be helpful if anyone has them. Thanks again!

Thats probably the issue. The bilge pumps dont prevent siphoning. IIRC, the center ballast sitting below water level will cause it to fill on its own unless you replace them with the original pumps or add a vented loop

Brian B
06-18-2011, 12:51 PM
Mine to.

A few trips ago my center ballast broke, so I pulled it out while waiting for a new one. One day I noticed the bilge was running overtime. I looking into the ski locker and water was pouring in from the fill line. It was siphoning.......

My boat has shut off valves in the lockers. I plan to start using them when I'm not skiing.

skongolf
06-18-2011, 01:49 PM
Yeah, I wondered if those dials on the drivers side rear locker would shut off the ballast system when not in use. If they will, I will deffinately do that next time out. When I have the boat home next time, I will take a better look at the pumps.

Jeff d
06-18-2011, 09:11 PM
If it's got aerator pumps just put a vented loop in the fill hose and mount it somewhere above the water line. That should take care of the siphon effect.