View Full Version : Lenco Trim Tab Actuator

06-07-2011, 09:35 AM
Anyone ever have one go bad?

Mine stop working on Sunday. Pull it out this morning and took it apart. Seems the lower seal had gone bad and the gears and motor were full of water.

07-08-2011, 12:49 AM
I just had the same exact thing happen to me. It filled with water and hydro locked the actuator. I'm hoping that drying her out and replacing the seal will fix the problem.

07-08-2011, 02:44 AM
Same here... Worked fine last year, this year it's worked maybe twice, now nothing. Makes a sound for 'up' when it's already all the way up, but no sound for down...

I'll pull it and let you know if it's full of water...

07-08-2011, 07:22 AM
I replaced it. I called lenco and they gave me the number to one of their resellers down in FL.

07-24-2011, 05:08 PM
Managed to repair mine, it was only a simple problem in the end. The bottom seal blew out and it filled up with water. Took it all apart, cleaned and dried it all out, buying a new seal this week and all should be good.

09-04-2013, 03:14 PM
Hate to dig up an old thread, but anyone know a good place to order an actuator from? What have you guys paid for yours? Did the self refurb work? Thanks, Nate

02-04-2014, 01:38 PM
Anyone know model number for trim actuator on a 2008 x15. Also mine died because water was getting in via wires I believe as core was wearing on swim grid. gonna grind out the grid to make more room. I did get motor to run but gears must be broke. has anyone pulled a unit apart?

02-04-2014, 01:46 PM
I dont see why you couldnt order one from your local MC dealer. I see Ebay has these as well.