PDA

View Full Version : Dash Guages Out


scocs15
05-29-2011, 07:58 PM
I have an '06 X2 and the dash guages went out today, digital and needle. The boat would start, but that was about the only electrical success I had on a bad day out. The boat did take on A LOT of water b/c it was so windy out. I'm wondering if something shorted out or if I tripped the main breaker or blew a fuse. All the breakers under the drivers side were ok. The guages were working on earlier in the day, then I noticed the depth guage was WAY out of whack. A little bit later it was out.

On another issue, and I don't think the 2 are realated, but who knows, the engine was running fine then all of a sudden it had no power. I couldn't go faster than no wake. It appeared to be running hot, so i didn't know if something went wrong and a safety deal kicked in to keep the engine running slow.

Anyway, it was not a fun day on the water today. Any help I'd appreciate.
Thanks.

Jerseydave
05-29-2011, 09:47 PM
Just some guesses:

-Bad connection at battery cables/ bad ground at engine block
-Alternator not charging
-Weak/bad battery?

scocs15
05-30-2011, 09:40 PM
Turns out it was a low battery. I added a 2nd battery and unknowingly hooked up the dash electrical lines to that battery which also runs the stereo. The battery was drained from running the stereo while we were parked. The ground nut behind the dash was also loose which didn't help the situation. Everything seems to be running ok now.

JRLx30
05-31-2011, 12:53 AM
I suggest adding a perko battery switch if you have multiple batteries.