PDA

View Full Version : LT 1 Water pump?


mlloyd
05-29-2011, 01:07 PM
I would like to replace the leaking water pump on my 1996 LT- 1 with a new one from NAPA. I will buy a new t-stat from my Mastercraft dealer. The 1992 Corvette water pump "Looks" like the same pump. Any reason why this will not work? Thanks

SS LS1
05-29-2011, 01:40 PM
I believe the NAPA one should work fine IIRC. But I would try a search here to be sure and in the General Team Talk area. I remember there was a thread about the LT-1 water pump and using one from the auto parts store in the past.

JimN
05-29-2011, 04:14 PM
I would like to replace the leaking water pump on my 1996 LT- 1 with a new one from NAPA. I will buy a new t-stat from my Mastercraft dealer. The 1992 Corvette water pump "Looks" like the same pump. Any reason why this will not work? Thanks

As long as the '02 pump is for reverse cooling, it should be OK.

billr
05-29-2011, 04:53 PM
I got mine from a Chevy dealer, as it was the same price as NAPA. It had one more hose fitting that I had to block off. Painted it black and was good to go.

mlloyd
05-29-2011, 06:40 PM
Thank you for your input. I feel like this is something I can do, just wanted to throw it out there and see if someone has had trouble. I am leaning toward the 92 corvette because there are no holes to plug. Thanks

DrJ
05-29-2011, 07:46 PM
I had the same issue as Bill. I purchased one from NAPA and it worked great! There was one extra hose fitting on the NAPA pump but it worked just fine after I put a stopper in the extra hole. Used it for four seasons before selling it and never had an issue. Good Luck

JimN
05-29-2011, 09:11 PM
Thank you for your input. I feel like this is something I can do, just wanted to throw it out there and see if someone has had trouble. I am leaning toward the 92 corvette because there are no holes to plug. Thanks

A plug might cost $2. It's not worth worrying about if the only pump available has the extra hole.

blackcreek
05-30-2011, 09:36 AM
I would buy the vette one if I had to do it again. I can't remember which exact car model of pump I purchased but the steel hose on mine came out and hit the support plate in front of the pump(97 prostar 205 LT1). The pump body's are all the same but the steel heater hoses run different directions for the various car models. I had a machine shop just tap a npt plug in the hole after I pulled the hose out. They only charged 10 bucks but it was still a hassle.

http://i91.photobucket.com/albums/k304/blackcreek123/PICT2536.jpg

This is the only picture I have saved right now but you can see the thermostat support plate in front of the pump. The replacement water pump I bought had a steel hose that hit the plate on the right side. I don't know if the support plates are different on your model.

mlloyd
05-30-2011, 10:42 PM
Thank you for your replies. I dont see any problems with the NAPA pump.