PDA

View Full Version : 2008 X2, multiple issues, power reduction mode, heatercore steam


OkanaganX2
05-24-2011, 12:39 AM
I recently purchased a 2008 X2, (maristar 200) without seeing or trying it in the water.

The boat appeared to have sat for a long time, and appeared winterized. (coolant hoses disconnected, knock sensors removed)

Now my attempt to summerize it! What have I done?
-Bought batteries, since the previous ones were stolen from it. Installed them.
-Reconnected all coolant fittings in the engine compartment.
-refit knock sensors, but didnt get them to fit all the way in flush due to rusty fitting
-Pumped out Hurth Vdrive milky transmission fluid, replaced with 15-40. (water infiltration???)
-checked that both bilges work automatically and manually.
-opened a water tap valve found on engine rear port side. (is this for a the heater or for a shower i cant find??)
-opened an engine hull valve on port side

My attempt at putting it in the water today, ugh, ugly.
I started it, had good oil pressure, had nice steady build up of engine coolant temp. Nice idle
Took it out nearby the launch site, just slowly, until i saw engine temp up at 160 and just hovering.

Then I noticed the boat was in Power Reduction Mode, wouldn't rev over 3000 RPM, and sometimes only 2000 RPM, like a pronounced rev limiter. (would knock sensor fitting cause this?)

STEAM STEAM STEAM billowing from helm heater vent and dash! (is this why the engine and hull valves may have been shut?)

thanks for any help you can offer this X2 Newbie

OkanaganX2
05-24-2011, 12:43 AM
Also have lots of warm water in the front bilge area, under the inspection cover, and the bilge automatically pumping it out quite often.

sand2snow22
05-24-2011, 01:00 AM
Repo??????

snork
05-24-2011, 09:10 AM
Broken heater core?

OkanaganX2
06-01-2011, 12:39 AM
Issues resolved!

heatercore was at fault and leaking badly

and, ready for this...

Perfect Pass was on, limiting the engine speed to 3000rpm