PDA

View Full Version : New LT-1 Questions....


Locascio
05-17-2011, 12:42 PM
Hey all,
Just bought a new (to me) 1999 Prostar 190 with a brand new LT-1 (replaced as a result of freezing by the previous owner). I have a couple questions:

#1 - What type of break in should I perform, for how long and when should I do the first oil change?

#2 - I have read alot on here about watching the temp on these. Had it out last night first time and it ran around 160 deg, is this "normal"? Also, the oil pressure was near 80 psi, seems high to me but what do you guys think

Thanks fella's, super excited about this boat....my first Mastercraft!

Jason

scott023
05-17-2011, 12:44 PM
Not sure on your specific answers, but welcome to the MC family. Make sure to get pics up of the new toy too.

Jorski
05-17-2011, 12:47 PM
160 is exactly the correct temp.

Locascio
05-17-2011, 12:52 PM
Oh, Here are the photo's:

1999 Master Craft Prostar 190 w/ 331 hours and a brand new LT-1 Long block...

06x2
05-17-2011, 01:01 PM
Nice boat congrats! Looks cheery

The8Ball
05-17-2011, 01:13 PM
Care to share the price of the new LT-1 engine? Would be interesting to know much of the boat's value is engine vs. hull.

Bouyhead
05-17-2011, 01:41 PM
Sweet boat & welcome to TT. As far as the break in goes just vary your RPM's for the fist 5-10 hours. No excessive idling & no extended runs at WOT (wide open throttle) Most folks change there oil every fifty hours. Use any good quality oil that makes you feel good. Sorry no experience w/ the LT1 but lots of threads here.

Good Luck!

EricB
05-17-2011, 02:04 PM
Download a copy of the Owners Manual from this site. All your break-in info is in there and maintenence schedules.
As far as engine temp goes, 160 deg. is spot-on. Shouild run there and remain steady. The temp will raise after you shut it off after a ski run, but will drop back down and run at 160.

Locascio
05-17-2011, 02:09 PM
Care to share the price of the new LT-1 engine? Would be interesting to know much of the boat's value is engine vs. hull.

The previous owner had one installed at a mastercraft dealer in GA for $7K. Came with an 18 month nationwide warranty that is in my name. I think it worked out pretty good for me....

Thrall
05-17-2011, 08:24 PM
Nice boat! Loved the LT-1 in my '96.
Temp and oil pressure are spot on. Realize the LT-1 has 2 thermostats unlike the TBI engines. 143 deg in the bottom and 160 deg up top with a little hole drilled through the flange. Just an FYI for future reference, order the specific thrermostats for the boat, or make sure you copy the existing hole exactly with a automotive tstat.
Poeple say watch the temps on the vette motors because they have aluminum heads and are more subject to damage from overheating vs iron heads on the other small blocks. They have reverse cooling meaning the water runs through the heads first instead of the block.
Other than a bad ECM (nothing to do with it being a LT-1) mine ran flawless for over 500hrs and the new owner is rolling it still.

1redTA
05-17-2011, 10:31 PM
the LT1 does not need a break in.... the engine is a roller engine and does not have flat tappets to worry about. start it up, make sure the valve lash is correct, good oil pressure, good water temp and WOT if you want.

I would change the oil and filter after a run for the first time