PDA

View Full Version : Bilge Pump WaterTight Connector Replacement


bonza
05-11-2011, 12:41 AM
Hi

My Bilge on X-Star has gone and need to replace it. Got a new pump but it comes with bare wires. The old connector seems in good condition and it is a triangle connector with 3 wires going in. It looks watertight.

Does anyone has any advice on how to do it? Or do I need to buy new switch?
In Australia they do not sell switches like this I was told by one good shop :(

If I can mount the old I have the soldering skills etc

Any help much aprecitad

BNIROOSTER
05-11-2011, 07:09 AM
Not exactly sure what you mean, if the new bilge doesnt have the connector on it look for the push tabs down inside the old connector and find something small to stick down into and depress the tabs that release the connector from the wires. replace on your new pump and pack with dielectric grease.

bonza
05-11-2011, 08:21 AM
Hey folks, no dramas, managed to replace the plastic connector at the end of bare wires if that makes sense.

A bit of messing about as the pins were hard to re-fit the wires in but pump works so i am really happy. Thanks for your help.

i didnt manage the grease, in the long run will have to replace 2 plugs I reckon - female and male connector.

Now onto next subject - my trailer ;)

Barefooter92
05-11-2011, 11:26 PM
Yeah I feel your pain. Replaced mine last week. I cut the old connector off the bad blower and soldered it to the new raw ends on the good blower. I then double shrink wrapped it for spark and waterproofing. Works like a champ!

bonza
05-12-2011, 02:43 AM
im not sure what is better - maybe your option actually

I took apart the plug - taken out a little green bit and rewired the plug onto new cables.

The pins however do not look new and the little clip did not bolt in as it was from factory.

I am not sure where would you get a new clip like this though - not in Australia that's for sure