PDA

View Full Version : 2007 X-45 Tower lights wont go on..


x-swagger
05-10-2011, 06:22 PM
So here is my tower, it has the lights on the two outer cans. 66467

here's the problem. The forward facing lights were struggling to come on for a while. Now, only the port side light will come on, if it even does at all. It goes in and out and is very odd.

I know the bulbs aren't out, because if i tap on the front of them they flicker just a bit. I guessed perhaps they are just loose inside the housing? Not sure...

Does anyone have any advice or help on how to troubleshoot this????

kskonn
05-10-2011, 06:39 PM
sounds like loose connections either to the bulbs or in the wiring.

venetrex
05-11-2011, 08:02 AM
Connectors are probably corroded. The cans with lights do not seal air tight. David from earmark makes nice plates to cure this problem. You have to take the speakers out to get at the connectors. They may be suck when you take the screws out mine were. Use a heat gun to heat up the grill and the rubber that gets stuck. Then use an allen wrench to pry at the screw holes to get them out. You don't want to scratch the anodized cans. You'll see the bullet connectors in there. If they are really bad you probably should solder/crimp new ones on. The light housing comes off with 4 allen screws.

mastercraft210
05-11-2011, 02:31 PM
Change the 2 lights.When they flicker when you tap on the light ist means that the wire from the lamp makes contact to eithother.
Or get a gauge to check the voltage on the wires in the speakers.