PDA

View Full Version : 2002 x star check engine light?


bjw444
05-08-2011, 10:16 PM
Hello i have a 2002 xstar with the 330hp LTR motor. Check engine light /alarm come on and stay on when boat is running. Boat runs great and all fluid levels are dead on.

I have read that the problem can be a bad knock sensor. I may try replacing that.

I have a nice snap on scan tool and was wondering if i can read trouble codes with this?


Thanks.

76S&S
05-09-2011, 07:54 AM
Hopefully Jimn or enginenut will run across your thread. I would like to hear what the problem/solution is.

JimN
05-09-2011, 08:23 AM
Hello i have a 2002 xstar with the 330hp LTR motor. Check engine light /alarm come on and stay on when boat is running. Boat runs great and all fluid levels are dead on.

I have read that the problem can be a bad knock sensor. I may try replacing that.

I have a nice snap on scan tool and was wondering if i can read trouble codes with this?


Thanks.

Don't just throw parts at it. Do a visual check first to look for loose wires and plugs, then scan for codes.

If the scanner is new, it may not work for OBD 1 (the older system, and it's what the older boats used because they didn't have O2 sensors or catalytic converters). IIRC, they changed to OBD II in 2003.

As long you verify that the diagnostic system is OBD 1, you can use your scanner as long as it's compatible. Or, you can use a paper clip,bent so it can be inserted into terminals A and B on the diagnostic port at the rear of the engine. You'll need to watch all of the flashes, so I recommend inserting it before turning the key to ON. It will flash once, pause and flash twice. This designates 12 and it will show 12 three times before proceeding to any codes, which will be standard code numbers.

bjw444
05-09-2011, 09:02 AM
Are the terminals labeled? Or how do I know what a and b are thanks

JimN
05-09-2011, 09:50 AM
Are the terminals labeled? Or how do I know what a and b are thanks

Remove the cover and you'll be able to see the letters in the plastic. A and B are next to each other.

bjw444
05-09-2011, 09:54 AM
Awsome! I'll check it out this afternoon when I get out of work!! I'll keep ya posted

JimN
05-09-2011, 10:05 AM
Awsome! I'll check it out this afternoon when I get out of work!! I'll keep ya posted

As I posted before, verify you have OBD 1- MC or Indmar will be able to tell you.

bjw444
05-09-2011, 11:06 AM
http://www.troublecodes.net/GM/

Great reference for obd1 testing and code list

bjw444
05-09-2011, 03:14 PM
So I tested my ecu and I'm getting code 22 what is that???

brucemac
05-09-2011, 03:18 PM
not sure this is right, but i found this:
http://www.gnttype.org/maint/malf.html#22

JimN
05-09-2011, 03:34 PM
So I tested my ecu and I'm getting code 22 what is that???

Throttle Position Sensor reading low. Make sure the plug is inserted completely and try it again. If you have a multi-meter, unplug the harness and probe the black wire for resistance to ground and the blue wire for 5VDC. The gray wire is the return to the ECM and if you measure the TPS's resistance (you won't get accurate info but if it's really bad, you'll see this), you'd need to measure from the pin that corresponds to the gray and blue pins. The resistance should decrease as you go from the idle position to WOT (Wide Open Throttle)

Do the voltage test with the engine OFF, key ON and if you check the sensor for resistance, you don't need to do anything with the key.

bjw444
05-09-2011, 04:31 PM
Thanks Jim I took it off and it was wet inside. I went to the auto parts store and they crossed the numbers and got a new tps, installed it and bam no more trouble code.

Also I talked to indmar and they gave me a link to free service manuals that go over testing and fixing procedures. I'll post link soon!!

bjw444
05-09-2011, 06:14 PM
ok boat is running better now check engine light went off but buzzer still going off???? what gives?

What triggers the buzzer?

kskonn
05-09-2011, 06:28 PM
is it the low voltage alarm?

bjw444
05-09-2011, 06:50 PM
I don't think, I have 14 Volts to the gauge. Anyone know how to reset trouble codes after problem is fixed??

djkslc
05-09-2011, 06:57 PM
Agree on the low voltage beep. As soon as the battery gets up to charge the beep should go away. Seems to happen every spring to my brother in laws boat - battery charges with the alternator for a few minutes and beep stops.

bjw444
05-09-2011, 08:29 PM
I just had the boat reading 16 volts with battery charger and buzzer was still going off