PDA

View Full Version : Fuel pump And relays


bob & kim
04-30-2011, 10:56 AM
I have a 04 X Star with the 6.0 Cadilac motor. Recently I had a fuel pump relay go out and also another relay go out,is this common and how many relays are there. I also heard from another X Star owner that the fuel pumps should be replaced every two years,is this true has anyone else had these type of problems. My Xstar has only 240hrs on it.

Jerseydave
04-30-2011, 04:03 PM
My '05 X-star MCX has the original pump with over 310 hours, but I am going to replace it so I don't have any problems this season. IF you have never changed your fuel filter yet you should at least remove the pump and change the filter.

I'm not sure about relays, maybe someone else can chime in.

JimN
04-30-2011, 05:33 PM
I have a 04 X Star with the 6.0 Cadilac motor. Recently I had a fuel pump relay go out and also another relay go out,is this common and how many relays are there. I also heard from another X Star owner that the fuel pumps should be replaced every two years,is this true has anyone else had these type of problems. My Xstar has only 240hrs on it.

If you still have the bad relay, cut the plastic open and look at the contacts- if they look burnt, have the pump checked for current draw to find out why it burned. The relay should last a long time and should be rated for 30A. There's one relay for the ECM, one for the Ignition system and one for the fuel system.

I would suspect that the battery posts have been loose or dirty or the ground point on the motor is loose or dirty/corroded. Either will cause things like this to fail. Have you replaced the starter?

bob & kim
05-05-2011, 05:43 PM
I havent replaced the starter we just got the X star and its our first boat. Thanks for the info