PDA

View Full Version : Fixed my leak..I hope


ahhudgins
04-27-2011, 07:49 PM
Iíve noticed that my carpet on one side of the V-drive will get wet from time to time. Noticed it mostly after pulling kids on the tube so it gave me a great reason to get them on skis and leave the tubes in the shed.:D I went out in the boat by myself for the first time this weekend and the carpet was fine while driving in a straight line. After weaving down the lake I raised the sun deck and noticed a line of water dripping down the carpet on the side of boat. Iíve never been a big fan of the euro platform on my Maristar 200 so I figured I would pull the rub rail off and reseal it. The rub rail was attached with screws until I got above the water line and then I found rivets, just about exactly where the water was entering the boat. Peeled the carpet back and found sealer only at the water line, not a drop in the seam above the water line or on the rivets. Cut the old sealer off and sealed the seam up as far as I could reach. Iíll take it for a test drive this week before I glue the carpet back. Itís a seam on a boat, it needs sealer on it!!

chawk610
04-29-2011, 11:27 AM
Agreed! Water takes the path of least resistance! Good investigative work!!! Keep us posted!

ahhudgins
05-02-2011, 09:42 PM
Agreed! Water takes the path of least resistance! Good investigative work!!! Keep us posted!

Took it out this weekend and did powerturns (slides) for severals hours (just kidding) and not one drop of water. One small spring project out of the way.:)