PDA

View Full Version : X-15 Tower Question


Trig2275
04-21-2011, 07:53 PM
Hey guys. I'm new here and just bought my first mastercraft and of course have two quick questions for you. I have a 2010 X-15 with the ZFT3 Tower with 4 speakers and I noticed that in choppy water the tower squeaks on the port side. Has anyone else experienced this and if so any remedy? Also I bought the boat from a private owner and it didn't have the cooler in it that goes under the seats. Is that cooler just a standard cooler I could pick up anywhere or is it specific to the boat?

Thanks,

Trig

GoneBoatN
04-21-2011, 08:22 PM
I had a queak on the starboard side. It was coming from the brace that runs from above the wakeboard spinner rack to near the speaker. That brace was set so that it was rubbing the attachment point very near the ball joint (for lack of better discription). There was a nut that "sets" where the eye bolt containing the ball joint. I adjusted it so that it would not rub and the squeaking went away.

The cooler that came in mine was an Igloo Marine 36QT
Manufacturer: Igloo
MPN: 6778,
Product SKU: IGL-6778


If it were me I would replace it with the same as the handles sit in those little recesses in the fiberglass on the side.

I found it right away using google.

Trig2275
04-21-2011, 08:41 PM
Thanks for the quick response. That sounds like the spot for sure. I definitely want to get the same cooler that came with it originally. I appreciate your help!

lanep82
04-29-2011, 09:50 AM
The cooler that came in mine was an Igloo Marine 36QT
Manufacturer: Igloo
MPN: 6778,
Product SKU: IGL-6778


If it were me I would replace it with the same as the handles sit in those little recesses in the fiberglass on the side.

I found it right away using google.

Do you, by any chance, know if the same cooler will fit nicely in a 2008 X-15? When I bought my used boat, the cooler was missing from it as well. Thanks, in advance!