PDA

View Full Version : Just bought a '99 Maristar 230


hz900
04-21-2011, 01:36 PM
I just bought a Maristar 230 with the Corvette LT1 engine. I have had a Prostar 205 for the last 5 years so I'm not new to inboard boats. What I want to know is any general information I can get on trouble spots/issues these boats have, or this engine has. Any maintenance that I should be aware of that will be required? And just basic info any of you maristar owners think might be of importance.

Engine is spotless and cranks right up and the interior is in great shape and will show nicely when I get it cleaned. The hull on the other hand is in some dire need of TLC which I am starting a thread in the Appearance section for pointers on that.

03geetee
04-21-2011, 02:56 PM
Congrats on the new boat, you wont find a better group of guys to help out then this site right here.

JTR

FrankSchwab
04-21-2011, 03:04 PM
Congratulations!

No big issues on these boats that I'm aware of, other than getting to the back of the dash is a royal PITA. I think your year moved to the in-tank fuel pump (mine is an external electric), but I haven't heard that they have as many problems as the early 2000's in-tank pumps.

If you store water toys in the engine compartment, people report getting quite impatient with the opening/closing times. Someone on here removed the motor, added some gas shocks and a latch, and turned it manual. I've seriously considered that mod.

The Ski wake isn't great on mine, and I don't imagine it's better on yours. I've considered a retrofit trim tab, as it's been reported to make the wake much better.

Let me know if you have any questions, I've done quite a bit of work on mine.

/frank

LaRue
04-21-2011, 09:48 PM
Photos!!! I have a 2000 210 Maristar. Only had it one full summer. Power sundeck is kinda a pain but not so bad. You get used to it. Ski wake is no prostar but for open waterskiing it does just fine around 31-34 mph. Assuming you have an MDC box under dash, speedo runs into it, that has been known to fail. When winterizing make sure you diconnect speedo from MDC box. Water can get in there and freeze. Ours has run great so far. Enjoy the room,storage, and ride:D

davidstan
04-22-2011, 08:30 AM
just sold my 99 210 and never an issue. i tried once to use an impeller 2 years and got caught so from then on changed impeller every year. Went with the new Maristar hull and love it just as much.

hz900
04-22-2011, 10:41 PM
Thanks for the replies. I bought it winterized, but it looks like the dealership the previous owner had it done at did if right and hooked everything back up so all I have to do is charge the batteries and turn the key. I'm testing it tomorrow, I'll report back on how she does. And I'll get some pics, however the hull is pretty rough, gonna need some TLC to bring it back to shine. I want to make sure all the mechanicals work first though.