PDA

View Full Version : Blower Trips Breaker


scocs15
04-03-2011, 04:12 PM
I have a 2006 X2. Whenever I turn the blower on nothing happens, then after about 3-4 seconds the breaker trips in the drivers panel. It takes about 30 seconds or so before I can reset that. Any ideas???

The toggle switch appears to be working ok. The light on the tip turns on when I flip it up to turn on the blower. My guess is the blower motor is out or I have a short somewhere. Is it possible someone hooked the toggle switch up wrong? I just bought the boat so I haven't done anything to it yet. I'm just going over it to see what is wrong.

erkoehler
04-03-2011, 04:14 PM
Replace the blower, that will fix the problem.

scocs15
04-03-2011, 04:19 PM
Thanks. I was hoping that was all it needed... of course I don't know how much a blower will cost yet though.

erkoehler
04-03-2011, 04:27 PM
Thanks. I was hoping that was all it needed... of course I don't know how much a blower will cost yet though.

They're not too bad, under $100.

Luv2Ski
04-03-2011, 06:00 PM
Probably blower, if you want to be sure, just disconnect it and see if the breaker still blows. If not, you know the short is at the blower. Might as well put a meter on there while you are at it to be sure it is getting 12v.

scocs15
04-03-2011, 07:12 PM
Thanks guys. I got the blower off and it was seized up and corroded. Looks like it will be a fairly easy fix this time. Hopefully this is all it will be.

thatsmrmastercraft
04-03-2011, 08:55 PM
Replace the blower, that will fix the problem.

Ding! Ding! Ding! Winner winner chicken dinner!