PDA

View Full Version : LT1 on Maristar 225 1994


greenhornetst
12-09-2010, 01:29 PM
Hi

I have a MAristar with the lt1 engine.

Here is the problem the boat runs great in idle but if you push the throtle fast the engine will die ans you can hear some explotions from the air filter.

I found that all spark plugs are berry black (i change them and work thew engine for less than 30 mins)

I have allready cahnged the yak balv and the map and run an inyector cleaner but still the same problem.

I think the engine is floding to fast with gas because if you go slow on the throtle you will get the top rpm with no problem.

And also I get alot of black smoke.

Any ideas???

Thanks for your time

Francisco Villar

1redTA
12-10-2010, 09:23 AM
throttle position sensor, you can check most GM sensors with a volt meter. For example put the volt meter on low voltage <25 and turn the sensor on the throttle body while watching the volt meter. the volts should start at close to zero (idle) and go to 5 at wot the engine does not need to run just have power

Kyle
12-10-2010, 10:43 AM
If you use the volt meter you can use ohms or volts. Another thing I would look at with the meter hooked up to the tps is all of the mid range. Hook meter up as stated above. Open throttle up by hand. Do this slowly. You should have a constant change in the reading but it should be a gradual increase. If you get to a point where you are opening the throttle body and no change on the meter and then a big jump with a higher reading in the meter, the tps is bad.

This switch should work like a wall dimmer switch.

If it has the jump in it you boat will run fine up until the jump. Run lean for a second then spike and run crazy rich. It will also confuse you map sensor and mass air flow readings.

Good luck

greenhornetst
12-13-2010, 01:29 PM
Thanks alot

That was the problem with my boat the tps.

I change it and now it works great.


Thanks again for your time.

Now i have another problem when runing in idle, there is a lot of gas smell you cant put you skis on if you dont turn the engine of it smell very hard.

Is thera a way to conect a computer to de computer of the engine to check the injectors position???