PDA

View Full Version : 93 prostar throttle assembly


burner
11-08-2010, 06:55 PM
Hey guys, I've been having problems with the throttle assembly, it doesn't seem to register as in neutral. The throttle must be in the neutral position to start. Sometimes I have to play around moving the throttle from wide open position and back to neutral before it will start. I'm not looking to mess around trying to figure out whatever little part it may be. I just want to replace the whole throttle assembly at the drivers console. Where can I find this part? I would prefer new, but if someone has a used one in good shape, I would consider purchasing it. Thanks in advance for any help!!

Skipper
11-08-2010, 08:54 PM
Before you replace the throttle assembly, take a look at the neutral safety switch on the transmission. Just a small sensor with two wires. It is located on the transmission at the shift lever. You can disconnect it and test with an ohm meter to verify that it functions properly.

In my '87 I replaced the old Morse shifter with a new Teleflex ski boat shifter from Overtons.com. If you have to go that route.

tph
11-08-2010, 09:45 PM
Hey guys, I've been having problems with the throttle assembly, it doesn't seem to register as in neutral. The throttle must be in the neutral position to start. Sometimes I have to play around moving the throttle from wide open position and back to neutral before it will start. I'm not looking to mess around trying to figure out whatever little part it may be. I just want to replace the whole throttle assembly at the drivers console. Where can I find this part? I would prefer new, but if someone has a used one in good shape, I would consider purchasing it. Thanks in advance for any help!!

Do you have a picture. I might have the correct one.

mayo93prostar
11-08-2010, 09:46 PM
skidim
http://www.skidim.com/prodinfo.asp?number=MV3
if you want to buy a new one. Or overtons.

burner
11-08-2010, 10:52 PM
Unfortunately I don't have a picture, the boat is at the cottage and I won't be able to get out there for a couple weeks. If you have a picture of what you have, I should be able to tell you whether it's the correct one or not.

Jorski
11-10-2010, 11:39 AM
+1 on checking the neutral safety switch...much more likely that it is the problem rather than the throttle itself.

mayo93prostar
11-10-2010, 02:03 PM
burner, you can also adjust the shift cable back at the transmission in the event that the transmission is not in neutral and the shift lever is. Or replace the switch on the side of the tranny. It is easy to do and not expensive. Switch can be had from skidim or local dealer.

Luv2Ski
11-10-2010, 02:19 PM
Could also just be adjustment, be sure the transmission is in neutral when the throttle lever is in neutral (disconnect the linkage at the trans). Replacing the throttle assembly will not help, as mentioned in a previous post, the electronics that control starting are located on the transmission. The good news is that the switch is cheaper and easier to replace.