PDA

View Full Version : I need help!!!


Jax05nismo
09-10-2010, 01:18 AM
I'm sitting in my 89 tristar that I just bought. Right now she's filled with possibilities, however the previous owner had decided to rewire her without tagging wires. He bought all new gauges, a new bilge pump, and switches. I have all this equipment and a gang of non-terminated wires. My searches for the applicable wiring diagram have been futile. Can anyone here help me? I bought a fuse block, and have the requisite knowledge to do this the hard way but I'd rather not. Sure I could strip her bare, get out the test light, and start going to town, but damn that's a lot of work. Also, at some point, a battery isolator was installed. When I switch it to 1, the 351 starts cranking even though the ignition wires are not connected, or touching. Any clue?

Any response is greatly appreciated!

FrankSchwab
09-10-2010, 01:28 AM
Oh, man.

You could use something like this (http://www.google.com/url?sa=t&source=web&cd=2&sqi=2&ved=0CBoQFjAB&url=http%3A%2F%2Fwww.boatswainslocker.com%2Fupload %2Ffiles%2FP-Conversions.pdf&rct=j&q=nmma%20wiring%20color%20&ei=5rKJTMmbL5OCsQPbvomJBA&usg=AFQjCNFf4c3kRzzZFGmJF8WN6aLqpRS-VA&cad=rja) to match up the wiring colors to the meaning of the wire. In addition, this (http://www.mastercraftboats.com/teamtalk/showthread.php?p=581436) thread might help.

I don't have any help for the battery isolator; it sounds like a really bad installation. Rip it out.

/frank

Jax05nismo
09-10-2010, 02:20 AM
That boatswain sheet seems to make sense! Tomorrow I'll trace a few back in order to ensure accuracy, but I think that's the one! As for the switch issue, I'm certain that the previous installation is flawed. I checked the feeds at the starter and they are accurate, so it must be mixed up before the engine circuit breaker.

I appreciate you help,
Brad

Jax05nismo
09-10-2010, 09:11 PM
Why can't I find an actual wiring diagram out there? Everyone says they are around but no one actually has one.