PDA

View Full Version : ballast pump?


Workin' 4 Toys
07-06-2005, 12:29 PM
I have a factory ballast system in the back of my X7, where do I find the pump? It is a little noisier than it should be, I think there may be something lodged in it. Where do I find it and how do I get to it?
I still have yet to find anywhere to get an operations manual on the boat, and the owners manual is useless.

BG1772
07-06-2005, 01:56 PM
If it is in the same place as a 197, you need to take the floor out of the rear ski locker. I helped one of my friends change out the impeller pump last year. Wasn't a lot of fun, but wasn't that difficult. Depending on the year, the impeller may be too large. That is the reason that we had to get to my friend's pump. My friends 197 is a 2002.

Workin' 4 Toys
07-06-2005, 04:55 PM
If it is in the same place as a 197, you need to take the floor out of the rear ski locker. I helped one of my friends change out the impeller pump last year. Wasn't a lot of fun, but wasn't that difficult. Depending on the year, the impeller may be too large. That is the reason that we had to get to my friend's pump. My friends 197 is a 2002.
I have an '03. The impeller was too large...... I don't understand.... What did the pump look like, was it the same pump to pump in and also pump out but reversed?

BG1772
07-09-2005, 11:13 AM
In my friends boat it is a johnson pump. They look like a electric motor with a brass housing on the front. The housing is very similar to, but smaller than the water pump that is on your engine. These pumps have a six blade rubber impeller. The problem was that in an early modle of this impeller it was too large for the pump so the pump would only work in one direction or not at all. My friends pump would squeal and would not push water. The MC dealer told us about the impeller issue and ordered him a new impeller. Fixed the problem.

BG1772
07-09-2005, 11:14 AM
Oh forgot, yes the pump is reversable. same pump fills and drains.

Workin' 4 Toys
07-21-2005, 11:23 AM
In my friends boat it is a johnson pump. They look like a electric motor with a brass housing on the front. The housing is very similar to, but smaller than the water pump that is on your engine. These pumps have a six blade rubber impeller. The problem was that in an early modle of this impeller it was too large for the pump so the pump would only work in one direction or not at all. My friends pump would squeal and would not push water. The MC dealer told us about the impeller issue and ordered him a new impeller. Fixed the problem.
What did you have to tell the dealer to get you the "corrrect" impeller? I want to make sure if this is my issue, it won't come back.

BG1772
07-21-2005, 11:56 AM
We had told the dealer that the pump would not work and just squealed. The dealer told us that they had been putting an impeller in that was too large and the motor could not spin it. I don't recall if we gave the dealer a model number. The inital fix was to cut off every other blade on the impeller. After that the motor could spin it, but the performance was seriously lowered.

Workin' 4 Toys
07-22-2005, 03:33 PM
I told my dealer this story. I will see what they say. I did not come right out with it. I told them I was having a strange noise when the pump is running. And asked that they order me a new impeller anyway, just to make sure I get the correct size.