PDA

View Full Version : 2004 TT 197/ Bow nav light out


bareinnj
07-25-2010, 08:33 PM
Navigation light issue. Bow light out, anchor and mini tower light work fine. Took apart front light fixture-bulb seems good, filament fine and no corosion. I did not have a test light at the lake so was unable to verify current to bulb, but I doubt thats it . Does any body know how the wires are routed to the front of boat? I checked at the tower, which has never been folded, and wires seemed fine. The wires going into the bow light are black/black, btw.

bareinnj
07-27-2010, 09:46 AM
Anybody know tthe routing and best access to wiring for bow light? Thanks

east tx skier
07-27-2010, 09:52 AM
My experience isn't vast, but every time I have seen a bow light go out, it has always been the bulb.

bareinnj
07-27-2010, 10:28 AM
Thank you, your response is appreciated. I hope it is that simple, but I have my doubts.

Gofast
07-27-2010, 10:37 AM
Unless you have been pulling wires for a stereo, i doubt the wire is bad. Mine was the bulb, even though it looked fine. Lot's of bouncing over the years is rough on the lights. I purchased mine at the marina for less than $10 for the whole thing. Bulb, enclosue etc.

No rodents on the boat right?

Good luck.

bareinnj
07-27-2010, 10:46 AM
Unless you are referring to those who wake/ski from my boat without paying for gas:mad:, no...no rodents. I was thinking along the bouncing theory as well, but having a connector of some sort break free. Again, the bulb "looked" fine but I am going to check with a tester as soon as I get the chance.

rhsprostar
07-27-2010, 10:52 AM
I have the same boat and year...it's the bulb, did mine last year.
Be happy its a simple fix.;)