PDA

View Full Version : Fuel consumption problems 99 prostar 205


jwskier
07-07-2010, 07:56 AM
I have a 99 prostar 205. I recently had to have the ECM replaced due to electrical problems... Since then, I getting terrible fuel mileage. I burned through a little less than 1/2 tank in about 1 3/4 hour on sunday. Any suggestions?

JimN
07-07-2010, 08:58 AM
I have a 99 prostar 205. I recently had to have the ECM replaced due to electrical problems... Since then, I getting terrible fuel mileage. I burned through a little less than 1/2 tank in about 1 3/4 hour on sunday. Any suggestions?

Who replaced it- did you just buy one and slap it in? That doesn't work because MC has a separate program for each boat model, not just the motor displacement like most other brands. If the old ECM isn't completely fried, take it to an MC dealer and have them find the Checksum and program ID of that and the one you're using now. I can almost guarantee the Checksum/ID is wrong. If it is fried and can't be used to get this info, contact MC and tell them the motor serial number and hull ID, so they can tell you which program you need. This can be e-mailed to the dealer and they can reprogram the ECM for you.

jwskier
07-07-2010, 08:40 PM
Thanks.. a local inboard dealer installed the ECM, he got it from Indmar and it should have been flashed correctly...

chico
07-08-2010, 09:39 PM
get it on a scanner to see if the ECM is controlling the timing,these things get terrible mileage if it is not.

ahhudgins
07-08-2010, 10:08 PM
Thanks.. a local inboard dealer installed the ECM, he got it from Indmar and it should have been flashed correctly...

I wouldn't bet on it.