PDA

View Full Version : No Forward and Reverse


rbooth40
07-05-2010, 04:59 PM
So went to the lake this last weekend in my 1989 prostar 190 with a powerslot trans., was running great all day had been wakeboarding behind it all day, then the last time my girl went to start pullin me it started to pull then just stoped and all i heard was the engine reving up, swam back to the boat tried forward and reverse and nothing. toke the cable lose from trans and tried to manually shifting it but still nothing. even just tried waiting it out and letting it cool down considering we were in the middle of a cove at heber but still nothing. kindof hear a weird clickin coming from the bellhousing i think its real faith cant really hear...

CLTMC
07-05-2010, 06:08 PM
I would start with the easy stuff, check trans fluid level, check trans lines connected to the trans cooler. Check bilge for any fluids.

If you are hearing a noise coming from the bell housing your flex plate might have came apart. The flex plate transfers the power from the engine to the trans. The transmissions in MC's are pretty much bullet proof. We repair broken flex plates, new and older boats at least 3 times a year at Charlotte Ski Boats. Fairy simple fix, you will have to pull the trans out of the boat.

Hope that helps.

dmminfla
07-05-2010, 08:55 PM
Check the damper plate first. Pull the starter and look for metal fragments.

jayderwin1
07-14-2010, 01:59 PM
is the flex plate and damper plate the same thing?

Bouyhead
07-14-2010, 03:25 PM
is the flex plate and damper plate the same thing?

yes it is.