PDA

View Full Version : 94 pro star loosing power


Norcal420
06-20-2010, 05:09 PM
Last weekend took boat out for the first time this season.for the first hour boat was working great.then all of a sudden it started to loose power and would not go over 3000 rpm.it never died just sputtering out and loosing power. So I changed spark plugs & fuel filter but no change.does anybody have any other ideas to problem would greatly appreciate it.
Thanks

jimmer2880
06-20-2010, 08:49 PM
Pls refresh my memory - is this carb, or TBI? If it's TBI, check the screen on the inlet side of your fuel pump. The only on my '95 has gotten clogged up a couple times before I finally put an inline fuel filter BEFORE (not after) the fuel pump.

André
06-21-2010, 06:29 AM
Pls refresh my memory - is this carb, or TBI? If it's TBI, check the screen on the inlet side of your fuel pump. The only on my '95 has gotten clogged up a couple times before I finally put an inline fuel filter BEFORE (not after) the fuel pump.

100% sure that this is your problem.There is a screen at the inlet side of your fuel pump UNDER the brass fitting.Got to clean mine every 2 seasons...same boat as you.
Easy fix!Good luck!

Good to see you back Jimmer!

jimmer2880
06-21-2010, 07:43 AM
....
Good to see you back Jimmer!

Thanks. It's good to be back. Had to go, learn about tractors for a while before finally finding my way back here :)

Norcal420
06-21-2010, 01:42 PM
whats the best way to clean the fuel fillter on the pump

chico
06-22-2010, 09:25 PM
Dental pick