PDA

View Full Version : Fuel sending unit bad???


Dawg
05-10-2010, 12:47 PM
My fuel sending unit is begining to act up. On the trailer and when we fist drop the boat in the water the fuel gage reads fine. After an hour or so the gage will not register at all. Is this an elecrical heating issue in the sending unit? To replace, is it difficult and would anyone know off hand what length sending unit fits the 02' PS 209.

TMCNo1
05-10-2010, 01:04 PM
My fuel sending unit is begining to act up. On the trailer and when we fist drop the boat in the water the fuel gage reads fine. After an hour or so the gage will not register at all. Is this an elecrical heating issue in the sending unit? To replace, is it difficult and would anyone know off hand what length sending unit fits the 02' PS 209.

Several choices here, http://www.skidim.chttp://www.skidim.com/products.asp?dept=1088om/products.asp?dept=1088, contact them to be sure or a MC dealer.
They are also available here too, under "Products", "Gauges and Senders", http://www.isspro.com/special.php (http://www.isspro.com/special.php)

helton333
05-10-2010, 01:15 PM
I got a reed style from West Marine - simple, great design - I have a 1989 PS - it is much better technology than the cork, elbow float that was in it and much better than the cheap auto parts store replacements.

timvan
05-10-2010, 01:33 PM
I have the cheapest operating cost of any boat, so my fuel gauge says, its always full.

What should I look for? Id assume sender? Where is it on my 2002 Maristar?


TIA for any help

MariStar-Man
05-10-2010, 08:37 PM
I have to call SkiDIm as well. My guage reads Full to. I just thought I ws getting great gas mileage...:o