PDA

View Full Version : 2007 Pro Star 197TT Perfect Pass no power


Lanedawg
05-04-2010, 04:22 PM
Hi all, I have a 2007 Pro Star 197 TT with the mcx engine. The perfect pass is the original that came with the boat and I put the Star Gazer upgrade in at the end of last year. When I put my boat in the water this year, there is no power at all going to the Perfect Pass display on my dash. Any thoughts, I am not real savvy with this type of stuff. Thanks in advance.

Lanedawg
CT waterskier:confused:

DemolitionMan
05-04-2010, 04:27 PM
Sodar should be along to help with this.

Sodar
05-04-2010, 04:27 PM
Hi all, I have a 2007 Pro Star 197 TT with the mcx engine. The perfect pass is the original that came with the boat and I put the Star Gazer upgrade in at the end of last year. When I put my boat in the water this year, there is no power at all going to the Perfect Pass display on my dash. Any thoughts, I am not real savvy with this type of stuff. Thanks in advance.

Lanedawg
CT waterskier:confused:

Call or email PerfectPass. For the cost of shipping to and from Canada, they will upgrade your MasterModule, reflash the software and install a "fix" to an issue the units had with voltage fluctuation. It should fix your problem for about $50.

Lanedawg
05-04-2010, 04:41 PM
thanks. I will do that. Sounds great.

macattack
05-04-2010, 10:38 PM
I assume after you upgraded to SG, the system worked?

Here's something you can try from PP's online troubleshooting guide (http://perfectpass.com/troubleshooting/Trouble_MC2007.pdf).

Problem Key is on, but PerfectPass screen does not become active and show data.
Check PerfectPass requires 12+ volts for start up. Check voltage on red wire (12 v) power source to Master Module. If backlight is ON, check screen contrast.
Check screen contrast Press Menu & UP Keys together, then press UP Key a couple of times. Does data re-appear?

Basically, ensure your battery is fully charged and is delivering 12volts...

As Sodar has already suggested, call PP (902-468-2150); they will be more than happy to help you troubleshoot your issue...mac