PDA

View Full Version : barefoot 200 Fuel Sending Unit


DaveBF200
11-29-2009, 08:54 AM
Hello-

I had to replace the fuel sending unit on my 1994 Barefoot 200. I tried to get the older 'float' version working but wasn't successful. According to the dealer the newer version (metal tube) would work fine. Just trim to correct length...I was skeptical but tried it. This is a two wire sensor.

It reads approximately 1/3 when completely full then goes down from there. Any ideas?

deereman
11-29-2009, 01:57 PM
i think those have to be calibrated if you trim them down. there should be some adjustment screws on top of the sender outside the tank. maybe someone else could back me up.

Waterski-Marcoisland
11-29-2009, 06:03 PM
http://www.mastercraft.com/teamtalk/showthread.php?t=7040


look here

uncleboo
12-10-2009, 04:16 PM
Hello-

I had to replace the fuel sending unit on my 1994 Barefoot 200. I tried to get the older 'float' version working but wasn't successful. According to the dealer the newer version (metal tube) would work fine. Just trim to correct length...I was skeptical but tried it. This is a two wire sensor.

It reads approximately 1/3 when completely full then goes down from there. Any ideas?

Couple of ideas: 1) Reset the gauge, take the gauge back out of the tank, put the magnet to the sticker on top, turn the key to acc, should read empty. Fill up your tank with gas, stick the sending unit back in, put the magnet back on the sticker on top, turn the key to acc and it should read full.

2) Did you cut it too short? I think you probably just need to reset the "full"; but also verify the length of both the inner and outer tubes on your new unit compared to the old one.