PDA

View Full Version : 2009 X-14v


JTNG
10-09-2009, 05:15 PM
When I leave the boat in the water for a week or longer the center balast reads 1/2 full when I come back to the boat. Any suggestions? I cant turn on the ballast drain and see if it has water or not, Mastercraft has the drain now under the boat. Thanks John:confused:

Witness140
10-10-2009, 08:27 AM
It is because the boat was most likely built with the yellow impellers in the ballast pumps. These impellers allow water to siphon past them into the tanks when the boat is sitting in the water. It happens at rest and it also has the opposite effect when underway. In other words, if the boat was moving through the water with the center ballast full, it will slowly siphon out past the impeller.

The solution is supposedly the green impellers.

My 09' X2 came with the yellows, and it siphons into the tanks at rest overnight, and siphons slowly out with the tanks full underway.

Solutions:

Replace impellers with green.
Turn off ballast valve at waterline when you leave the boat at night, until the next session.
Everytime you return to the rider after a fall, flip the ballast pumps to FILL, to top them off from the small amount that siphoned out underway.

OhioX14
10-10-2009, 10:56 AM
Do a search on green impellers on this site to learn more as they are the solution. I had the same issue with the yellow ones until I read about the green ones here. Mine would not only fill the center (KGB) at rest it would lose water from the back tanks while underway. I had my dealer order some green ones and ever since installing those all problems have gone away. If you can't get them from your dealer you can get them from the dealers that frequent this site.