PDA

View Full Version : Heater install 09 MCX


wakedoc
10-06-2009, 04:34 PM
Hi all, almost done with installing a heatercraft heater in my 09 X1 - but am struggling to determine the hose locations on the motor (MCX). One is pretty easy, the port below the port side fuel rail, but the other should be somewhere around the water pump - can find one. Do you have to tee into a water line? I have a y-pipe coming, but would like to hook it up so I can check leaks at the core etc (and I'm just impatient). Anyone done this on a 09 MCX?

rgardjr1
10-06-2009, 04:44 PM
I thought this post might help:

http://mastercraft.com/teamtalk/showpost.php?p=637774&postcount=6

bigmac
10-06-2009, 06:24 PM
This picture shows the location of the heater inlet hose. The return line (on my MCX anyway) is to a fitting on the circulating pump which is located on the water pump on the same side as the intake manifold fitting. There should be a plug there which you have to remove to put in the barbed fitting for the return heater hose.

That line, the one that goes to the circulating pump, is the one that would go to the fitting on the Y pipe. So, if you're going to use a Y pipe (recommended), you're better off running that hose to the Y pipe from the get-go, thereby avoiding having to screw around with putting a fitting on the water pump port. On my boat, the Y pipe goes on the intake line in front of the raw water pump, and that's on the opposite side of the engine as the heater valve.

wakedoc
10-06-2009, 10:02 PM
Thanks guys - the picture posted shows the port I can find, but I can't find another around the water pump. I might just have to wait for the y-pipe to arrive (thanks Bigmac, I was planning to put it in the raw water line before the pump).

Witness140
10-07-2009, 04:22 AM
Here's a Y install I did on an 06'.

Witness140
10-07-2009, 04:27 AM
Here's a shot showing where the factory fitting is going into the pump on my 09 MCX. Of course, like stated above, if you are installing the Y - save your time and don't even worry about this.