PDA

View Full Version : Rust on Motor Mounts


MC X-15
10-06-2009, 02:42 PM
So my 08 X-15 SS is starting to get some rust on the motor mounts. Anybody have a good remedy for this. You would think on a Salt Water Series boat they would use a material that doesnt rust. I have been spraying rust inhibitor on it very often and still rust. I was thinking of using a dremel and grinding off the rust then painting it with rustoleum paint. I feel that should work fine but was wndering what others did, and if they have had similiar problems. Also the top of my gas tank is getting rusty a little, i guess where the fuel pump goes in, andwas thinking about the same thing for that.

Thanks in adance
Rob

Witness140
10-06-2009, 04:28 PM
My 06,07, and 09 Mastercrafts have all shown some level or rust on the motor mounts in short amounts of time. The 08 and the other 07 that I've skied on also show it. Nothing incredibly substantial - and those were all fresh water boats.

kkkeating
10-06-2009, 04:50 PM
I go through twice a year and spray all metal parts with WD-40; have not had any rust or corrosion show up yet. Used to have a Wellcraft boat that I used quite a bit for ocean fishing. Did the same thing, but sprayed it monthly and had no problems with corrosion.

88 PS190
10-06-2009, 04:55 PM
I'd go like kkkeating but since you already have some rust I would scrub that away first, probably with some brass wool and wd-40, or breakfree clp, and that should keep that down.

When I got our 1988 there was quite a bit of surface rust I scrubbed this way with breakfree clp and now I just wipe the mounts, and the threaded bits of the adjusters down this way to keep them freed up.

thatsmrmastercraft
10-06-2009, 05:16 PM
I have become a big fan of Rustoleum Reformer. Its a primer that neutralizes rust and creates a rather durable primer. Might be an option, although there are some that don't believe in painting those mounts so that a crack would be immediately visible (at least in theory).