PDA

View Full Version : Help with wiring problems


tobaccoman2
09-21-2009, 12:13 PM
Labor day weekend the key switch started acting up and when the boat would start the starter would keep trying to start the engine. I unhooked the battery and every time I would connect the battery the engine would start turning over with the key in the off position. I replaced the starter and the key switch and now I get the same results. With the key switch completely unhooked as soon as I connect the battery the gauges all come up just like the ignition is on. Could this be a bad selenoid or just a short???? Please help!!!!

454Prostar190
09-21-2009, 12:35 PM
Labor day weekend the key switch started acting up and when the boat would start the starter would keep trying to start the engine. I unhooked the battery and every time I would connect the battery the engine would start turning over with the key in the off position. I replaced the starter and the key switch and now I get the same results. With the key switch completely unhooked as soon as I connect the battery the gauges all come up just like the ignition is on. Could this be a bad selenoid or just a short???? Please help!!!!

I had the same problem on my S and S one afternoon. The starter stayed engaged after I turned the key off. The battery then went dead and it I ended up getting towed back to the dock. The following weekend, I bought a new battery, ignition switch and starter solenoid. I installed the new battery and everything seemed to work. Took it out on the water and haven't had a problem since and this has been a few years ago, now. Still have the new switch and solenoid in my parts stash. My suggestion is to try a new battery first and go from there.

ski_king
09-21-2009, 01:36 PM
I think you need a starter relay.
http://skidim.com/images/R130001.jpg

I see skidim.com has this note:
* CAUTION * Test starter after installation.
If starter stays engaged, it is an indication of a low amperage problem. Check both ends of the battery cables and main grounds.

tobaccoman2
09-21-2009, 02:17 PM
Thanks for the info guys. The battery was bought in June 09 so I will get a new starter relay and see if that cures it. Thanks.

amber 6
09-21-2009, 02:50 PM
I had the same on my 82 Stars and Stripes went to local car parts shop put new solenoid in still kept engaging went to mastercraft got the solenoid and has never happened again I am sure the Skidim one will be fine but its scarey when it keeps engaging the starter and you have to rush to cut the power having said that the car solenoid which didnt work 10 the mastercraft one 45 but hey no Skidim over here.

Kevin&Annie
04-25-2010, 08:24 AM
I know this is an old thread, but I had the starter issue last week.(It only happened once and was fine the rest of the day)..I'm going to clean all the electrical connections and replace the relay..My question is: why didn't the relay from the auto parts store work? I want to get on the water today so I was going to hit O'riley's on the way.