PDA

View Full Version : HELP..X45 Wont START..


hullwatson
08-29-2009, 10:31 PM
My boat a 2008 X45 wouldn't start today. I was on the lake and turned the boat off to get skiers in and it wouldn't start. EVERYTHING else works.. It just makes a clicking sound when you turn the key. Do you think its the starter? bad battery? lose battery cable?
Any help would would be MUCH appreciated. :confused:

Carbon Dreams
09-03-2009, 01:20 PM
Combine the batteries with your Perko switch and hit the starter. Sounds like the start battery is funked. Check to see if you threw your belt and the alt is not charging. Good Luck.

flipper
09-03-2009, 01:32 PM
My boat a 2008 X45 wouldn't start today. I was on the lake and turned the boat off to get skiers in and it wouldn't start. EVERYTHING else works.. It just makes a clicking sound when you turn the key. Do you think its the starter? bad battery? lose battery cable?
Any help would would be MUCH appreciated. :confused:

Could be any of the above. I'd start with the cables and work your way down the list. See if you are getting power to the starter, bench test the starter if so.

MCRambo1
09-03-2009, 03:05 PM
Don't forget to check your kill switch!

CruisinGA
09-03-2009, 04:54 PM
Audible click from the starter but no turnover implies two things-

1) Failed (failing) starter solenoid
Short term- tap starter with a hammer, keep turning key, it may work every few clicks
Be careful with this, because if solenoid contacts are bad, they can weld together locking the starter "on," and often killing the starter, battery, alternator and flexplate in the process.

2) Insufficient current to starter.
Depending on the age of the engine, may be more likely than wearing solenoid contacts. Likely culprits are loose connections at starter or battery, corrosion, or a bad ground.

Judging by the age of your boat, I would suspect a loose connection more than anything else.

Good luck!