PDA

View Full Version : Need shaft seal help


hz900
08-10-2009, 12:15 PM
'92 Prostar 205 w/ 285 hp indmar

I am almost certain that I have a leak at the shaft seal. I have fixed all other leaks (water pump and mufflers) and am still getting a fair amount of water in the bilge, and it seams like it is multiplied when I am driving. What rope do I get? I see them on skidim but there are several different kinds and sizes. Also how much to I need. Is there anything else I need in the way of parts to do this.

Also does anyone have any instructions on how to do this, with pics preferably. I saw the instructions on skidim, but I would prefer to have some pictures of the process to look at as well.

Thanks.

TMCNo1
08-10-2009, 01:07 PM
'92 Prostar 205 w/ 285 hp indmar

I am almost certain that I have a leak at the shaft seal. I have fixed all other leaks (water pump and mufflers) and am still getting a fair amount of water in the bilge, and it seams like it is multiplied when I am driving. What rope do I get? I see them on skidim but there are several different kinds and sizes. Also how much to I need. Is there anything else I need in the way of parts to do this.

Also does anyone have any instructions on how to do this, with pics preferably. I saw the instructions on skidim, but I would prefer to have some pictures of the process to look at as well.

Thanks.

Here is two General Discussion FAQ tutorials, http://mastercraft.com/teamtalk/showpost.php?p=159060&postcount=31
and http://www.mastercraft.com/teamtalk/showpost.php?p=503319&postcount=52 (http://www.mastercraft.com/teamtalk/showpost.php?p=503319&postcount=52)
Try tightening the stuffing box first, unless you just insist on replacing the rope, even if there is plenty in there, but you can get some here, http://www.skidim.com/prodinfo.asp?number=PR18X17 for 1 1/8" shaft (PowerSlot) and http://www.skidim.com/prodinfo.asp?number=PR25X17 for 1" shaft.
A tag on top of the transmission will tell you the gear ratio.

Cloaked
08-10-2009, 10:42 PM
'92 Prostar 205 w/ 285 hp indmar

I am almost certain that I have a leak at the shaft seal. I have fixed all other leaks (water pump and mufflers) and am still getting a fair amount of water in the bilge, and it seams like it is multiplied when I am driving. What rope do I get? I see them on skidim but there are several different kinds and sizes. Also how much to I need. Is there anything else I need in the way of parts to do this.

Also does anyone have any instructions on how to do this, with pics preferably. I saw the instructions on skidim, but I would prefer to have some pictures of the process to look at as well.

Thanks.. Easy to do.