PDA

View Full Version : 97' ProStar 190 prop issues


novaman64
07-28-2009, 12:01 PM
So bought this boat used about a year ago, has been a great runner. Recently the misses was putting the boat on the trailer and managed to get it sideways while on the gas and put the prop through the running board and nicked the frame. Needless to say the prop is now injured.

I have priced out having it repaired and am also debating just replacing it (now is as good of time as any). We use the boat for wakeboarding about 60% of the time, slalom skiing about 20% and barefooting the remaining 20%. I was wondering what performance I would gain or give up by switching to a 4 blade prop. Also anybody know what size shaft I have (wow, that just sounds wrong), not sure if its 1" or 1 1/8"?

The current prop on it is a 13x13, standard 5.7l motor with a 1:1 tranny... Any advice would be appreciated.

Sodar
07-28-2009, 12:07 PM
Give ACME a call at (231) 796-2874 and talk to Bill. He will be able to set you up with exactly what you need for your application. Good Luck and enjoy the smooth benefits a new CNC'd prop from ACME will provide!

Also, OJ Props is on the board and can be contacted at (865) 458-5205 and talk to Eric. His user name on the board is EJ OJPROPS.... http://www.mastercraft.com/teamtalk/member.php?u=1537

novaman64
07-28-2009, 01:15 PM
Thanks for the heads up. I called ACME and spoke with Bill, seemed real knowledgeable and was funny when I told him I barefoot and wake board off the boat. He recommended a 13x12, and said try it for 30 days and guaranteed I would like it... Hmmm, now time for decisions...

novaman64
07-28-2009, 02:25 PM
K, well after reading a unch of reviews on here decided to order it... Got a 541 on the way, had 3 day thrown on so I coul duse it this weekend. Get to try barefooting and wakeboarding behind this bad boy. Gotta love friends that have houseboats....