PDA

View Full Version : X1 engine died - couldn't restart


tcmercil
07-06-2009, 09:28 AM
Well - of all weekends to have it happen on:

2006 X1 266 Hours -

Saturday - 4th of July, after a great Surf set in the crazy busy lake of Bear Trap, we were making our way back to Lake Wapogasset, when my engine sputtered and then quit on me. Couldn't get her restarted - fuel was 3/4 full - everything else seemed OK.

Clogged line? Bad fuel? Bad Fuel filter? I brought her home and changed the fuel filter and still had no luck? That's the extent of my engine skills?

So - fuel pump?
Thoughts?



The good news on this, is I met some great guys in an 2004 X2 - that saw me being towed to the boat launch and quickly came to ask what was going on. After talking a bit, and seeing I was out of commission - the offered me a pull the next Morning.... Many thanks to Kevin and crew for the great pull Sunday morning - the Mastercraft Family - obviously looks out for one another - - thanks again!

trickskier
07-06-2009, 09:49 AM
Have you ever run it out of gas?

bigmac
07-06-2009, 10:06 AM
Well - of all weekends to have it happen on:

2006 X1 266 Hours -

Saturday - 4th of July, after a great Surf set in the crazy busy lake of Bear Trap, we were making our way back to Lake Wapogasset, when my engine sputtered and then quit on me. Couldn't get her restarted - fuel was 3/4 full - everything else seemed OK.

Clogged line? Bad fuel? Bad Fuel filter? I brought her home and changed the fuel filter and still had no luck? That's the extent of my engine skills?

So - fuel pump?
Thoughts?



You pulled the fuel pump module out of the tank? IMHO, the problem is that, since that filter is BEFORE the fuel pump, if it does clog enough to kill the engine, it means there's no fuel going through the pump itself to cool it and it fries. Or is there another fuel filter somewhere on the 2006 models. They made a lot of changes in 2006, maybe adding another filter was one of them?

Anyway, yeh, sounds like fuel pump would be toward the top of your list of diagnoses. On the fuel rail, you'll find a bicycle-type Schrader valve. Turn your key on, listen for the pump to spin up for a few seconds, then push the valve and see if the fuel line is pressurized. If the pump spins up but there's no pressure, you have a bad pump. If it doesn't spin up, it could be a bad wiring connector or a popped breaker.

If you have a bad pump, you have three choices. One is to haul it over to Midwest MasterCraft and have them fix it. It will cost you around $500-600 (you are out of warranty). Another is to buy a new fuel pump unit and replace it yourself (pull the module same as you did to change the fuel filter, but you need to buy a fuel line disconnect tool at AutoZone or someplace). The new unit is about $350-$450. Third choice is to pull the fuel pump module and replace the actual pump itself. The replacement pump part numbers are usually listed as

ACDelco ep356
Advance Auto Parts E2044

Review this thread (http://www.mastercraft.com/teamtalk/showthread.php?t=24965&highlight=fuel+pump) for more info on that. The pumps typically cost around $100-$125.

If you choose option #3, review this thread (http://www.mastercraft.com/teamtalk/showthread.php?p=531882&highlight=fuel+pump#post531882) and several others on the same subject. Be aware that replacing just the actual pump isn't sanctioned by MasterCraft, and component repairs like that can be problematic and potentially dangerous. Review the threads and make your own decision. Note that on problem is removing the fuel line hose from the pump. Can be kind of hard to do without damaging it. Also note that in some cases the fuel flow problem has been kinking of that hose rather than pump failure.

tcmercil
07-06-2009, 10:22 AM
Yeah - I had pressure in the valve right away, but I blead out that fuel - - and tried to start it again - and then had zero pressure in the valve...

filter - yeah - it could be clogged - and enough to limit the fuel to the pump - causing failure on the pump - makes sense....

I've never run it below 1/4 tank -

I've got a call out to Ski Boat Solutions - Jim Contanous (spelling?) - - and he's coming to look at it on Wednesday - - but reading what is above, I'm 99% sure it's the fuel pump at this point.

Fantastic forum everyone....

bigmac
07-06-2009, 10:39 AM
MasterCraft is now using different pumps than they were in 2006. People that have disassembled the modules to replace just the pump have universally mentioned how the replacement Delcos and AirTeks appear to be much better made than the Federal-Mogul that came there from the factory, but as of about 2008 MasterCraft started using a different pump that is supposedly more robust. Bear that in mind when you replace - make sure you get this new Millenium pump that they're using, assuming that it will work for your boat.

tcmercil
07-09-2009, 04:19 PM
Well - it is indeed the fuel pump, but the problem - - $500 - and no one in Minnesota has one - actually Mastercraft themselve is out? So - - looking at the alternatives at this time....

Looking through all the aftermarket pumps now

jenglin
07-09-2009, 04:33 PM
Fuel pumps seem to be the problem of late for some. Knock on wood mine is still working good and it sounds like an expensive fix. OUCH!

flipper
07-09-2009, 04:55 PM
If I had one of the years that has the problem, I think I'd keep a spare in the boat. Way too many going out not to and risk having a messed up weekend

tcmercil
07-09-2009, 05:05 PM
yeah - I'm out of town - minus the boat for the next 10 days, but if I wasn't - I would be a bit more eager.... but still - I'm leaving again in 13 days and "need" my boat back.

The posts for the aftermarket fuel pump seem really good. I am honestly leaning that direction and actually picking up a spare just to have. The install doesn't seem all that bad.

rob935
07-12-2009, 05:52 AM
go for the aftermarket version , i know a guy who has gone through two fuel pumps in 12 months on his 07 x2 .... real pain and spoiled a number of good weekends...even though it was fixed under warranty doesnt make up for time lost on the lake .

bigmac
07-12-2009, 08:51 AM
It seems to me that pulling the fuel pump module out of the tank is the real pain. Doesn't look like disassembling it to change the pump itself would be a big deal, although most have reported that the attached tubing in the pump module is kind of hard to get off without damaging it.

I'd head down to an auto parts store and get the pump. While there, I'd pick up some extra fuel line tubing that won't kink, and I'd also get a Ford fuel line disconnect tool in order to get the fuel line off the module.

Reinstalling the pump module into the thank is kind of hard - the tank deforms enough that it's hard to get the bolt holes to line back up. Much easier if the tank is empty. Those bolts need to be tightened to 40 inch-lbs, according to conventional wisdom.

Kevin@MWMC
07-20-2009, 02:28 PM
Well - of all weekends to have it happen on:

2006 X1 266 Hours -

Saturday - 4th of July, after a great Surf set in the crazy busy lake of Bear Trap, we were making our way back to Lake Wapogasset, when my engine sputtered and then quit on me. Couldn't get her restarted - fuel was 3/4 full - everything else seemed OK.

Clogged line? Bad fuel? Bad Fuel filter? I brought her home and changed the fuel filter and still had no luck? That's the extent of my engine skills?

So - fuel pump?
Thoughts?



The good news on this, is I met some great guys in an 2004 X2 - that saw me being towed to the boat launch and quickly came to ask what was going on. After talking a bit, and seeing I was out of commission - the offered me a pull the next Morning.... Many thanks to Kevin and crew for the great pull Sunday morning - the Mastercraft Family - obviously looks out for one another - - thanks again!


Hey Tim! Been awhile since I have been on here, not sure how I missed this thread when reading through everything? It's Kevin with the X-2. Glad to hear you got the fuel pump all fixed and are ready to ride again. My bro just sent me an e-mail last night telling me he heard from you and that you got the boat going again for a good price.

Just let us know when you will be back up on Wapo and we'll have to meet up again! Hope you have a good time on your trip! :cool: