PDA

View Full Version : Back for one more question.....


Lopers22
06-30-2009, 10:09 AM
Alright boys, back for more.....
So I was the one that had the post yesterday about the alarm going off after having a dead battery issue on a 2007 X-2. So rather than recharge the battery I just bought a new one. I installed it and the boat fired right up. After about 10 seconds the alarm went off again, so I got it to stop by pressing and holding in the button on the dahsboard that switches your screen from temp, to depth finder, to hours ...etc. The alarm stopped. But something else happened, after driving around for about 5 minutes, the check engine warning came on and a more faint alarm went off. I looked at all the gages, temp was good, Voltage looked good, oil pressure was fine ...etc so I again pressed the dashboard button and got the alarm to stop. After this second alarm came on, I drove around for half an hour and everything was fine. So to test it out again, I turned the boat off, let it sit for a while and fired it back up. Same thing, original alarm went off, I reset it and got it to stop, and then 5 minutes later the check engine came on with the more faint alarm, I reset it and then it never came back on.
I am not concerned about the first alarm, everyone said that would happen with the dead battery issue, but it is this second alarm I am asking about. Like I said, the baoat seemed to run fine? Any ideas?

snork
06-30-2009, 11:03 AM
Your local dealer can diagnose it and then reset it so the alarm will stop or keep pressing the switch on your dash for the next 10 hrs.

corey
06-30-2009, 11:50 AM
Could be a couple of things, if temp, oil and the like are all good it could be as simple as a bad knock sensor.

Lopers22
06-30-2009, 01:13 PM
My biggest issue is the dealership is backed up for about 2 to 3 weeks with work here in town and I am supposed to leave this weekend to go boating out of state. So I was trying to see if anyoen thinks it is a major enough of an issue not to take the boat to the large lake 3 hours away????

Lopers22
06-30-2009, 01:14 PM
What are good level for the oil, temp, Voltage ...etc. Just so I knwo what to compare it to? None of the gages were to either extreme, right or left except for the gas obviously.

Lopers22
07-01-2009, 10:19 AM
Anyone????