PDA

View Full Version : Perfect pass surging bad


hawaiianstiln
06-27-2009, 02:44 PM
Everytime I take this boat out the PP surges really bad. I ride at 80 feet / 24.5 MPH. The boat will first surge at 23, then come all the way back down to 20, then it revs back up and does the same about 4 times before it finally gets to the speed that I have dialed in. I thought it was the KDW setting?? My default is 80 KDW and I try to set it to about 350, but the setting never seems to save.

Is it the KDW or something else that I need to make sure is correct.

The surging almost ruins one pass sometimes. There's another setting just below KDW and can't remember what it does. Not sure if it needs to go up or down on the setting on that one.

Any tips.

bigmac
06-27-2009, 03:05 PM
What model of Perfect Pass and what software version?


Check here for user manuals and troubleshooting.

http://www.perfectpass.com/perfect_pass_support.html

sand2snow22
06-27-2009, 03:28 PM
Call Perfect Pass. I recently had some trouble with my stargazer version. They said to raise the CS value and keep raising it by 100 until the problem is solved. Too bad I haven't been out on the boat since......:o

hawaiianstiln
06-27-2009, 04:24 PM
thanks, I will try that for sure! :)

pflcjl
06-28-2009, 06:11 AM
my friend has a new X14v and was having the same problems with surging.....dealer was clueless.....he finally called perfect pass in canada and talked with one of their software engineers....He took him through it in detail on what to do....it works perfect now...

bigmac
06-28-2009, 07:50 AM
Perfect Pass has historically been excellent about telephone calls for technical support.

hawaiianstiln
06-29-2009, 02:05 AM
I think I will call them sometime this week. Looked like all my settings were at default and since I load the boat down more than normal, this might be the problem and it's not accounting for the weight. I adjusted the KDW, NN, and CS all at the high points. however, I think I would rather just call PP and make sure. I don't want it to fix one problem and give me another.

sand2snow22
06-29-2009, 02:09 AM
I think I will call them sometime this week. Looked like all my settings were at default and since I load the boat down more than normal, this might be the problem and it's not accounting for the weight. I adjusted the KDW, NN, and CS all at the high points. however, I think I would rather just call PP and make sure. I don't want it to fix one problem and give me another.

I think you're on the right track. Says to raise the KDW and CS values for heavily weighted boats. Not sure about NN. I have to call them tomorrow, too......:(

Age Fighter
06-29-2009, 07:58 AM
My Perfect Pass seems to bog slightly right at 14 mph -- while we're speeding up to the 21-22 setting -- and while we're slowing back down to retrieve a boarder. Anyone had something like this happen?

bigmac
06-29-2009, 08:23 AM
My Perfect Pass seems to bog slightly right at 14 mph -- while we're speeding up to the 21-22 setting -- and while we're slowing back down to retrieve a boarder. Anyone had something like this happen?That's normal, I'm told - a slight hesitation as you accelerate and that just about exactly where it happens on my boat. I called Perfect Pass about it a couple of years ago.

MYMC
06-29-2009, 10:10 AM
I think I will call them sometime this week. Looked like all my settings were at default and since I load the boat down more than normal, this might be the problem and it's not accounting for the weight. I adjusted the KDW, NN, and CS all at the high points. however, I think I would rather just call PP and make sure. I don't want it to fix one problem and give me another.

Without knowing year of boat and engine size try a NN of 60 and a KDW of 170...you should be able to leave CS at the factory default (again depending on year etc).

sand2snow22
06-29-2009, 10:22 AM
Without knowing year of boat and engine size try a NN of 60 and a KDW of 170...you should be able to leave CS at the factory default (again depending on year etc).

He has a 2007 X2 with MCX....

Age Fighter
06-29-2009, 10:33 AM
That's normal, I'm told - a slight hesitation as you accelerate and that just about exactly where it happens on my boat. I called Perfect Pass about it a couple of years ago.

Thanks for the info -- and to clarify -- does "normal" mean normal as in nothing is wrong or normal as in a common problem that needs some adjusting?

MYMC
06-29-2009, 11:23 AM
He has a 2007 X2 with MCX....
I never did learn to read to the bottom of the page! :o

The numbers I posted should be good...

MYMC
06-29-2009, 11:24 AM
Thanks for the info -- and to clarify -- does "normal" mean normal as in nothing is wrong or normal as in a common problem that needs some adjusting?
Normal...this is where the "control range" is established by the computer.

rspiecha
06-29-2009, 03:21 PM
Call Perfect Pass directly, nice/helpful bunch of guys.

Rob