PDA

View Full Version : What is this broken connector?


alex
05-31-2009, 06:54 PM
What does this do? Check out the circled parts in the pic, i can figure out that much that they're supposed to be connected, but what does it do? where do i get a new part for the cables to connect to? it was this way when i bought the boat last year and everything is working, i think:)

André
05-31-2009, 07:19 PM
Neutral switch?
Transmission temp sensor?
What boat,year and transmission maker?

CantRepeat
05-31-2009, 09:25 PM
That looks like temp, the one with the cover still on it looks like neutral switch.

Gamble
05-31-2009, 10:53 PM
what Maristar said..........they yellow/brown wire is the nss.

snork
06-01-2009, 11:04 AM
Trans temp sensor. My wire broke and was an easy fix to replace the sensor. don't over tighten. But then I could be wrong

alex
06-01-2009, 12:02 PM
ok, thanx a lot. It's a 2004 X-star but temp seems to be right. Looks like it's an easy fix, so i'll just get a new one then.

CantRepeat
06-01-2009, 12:33 PM
ok, thanx a lot. It's a 2004 X-star but temp seems to be right. Looks like it's an easy fix, so i'll just get a new one then.

It doesn't measure the temp of the motor. It measures the temp of the tranny and it doesn't have a gauge output. If you over heat the tranny it should just make a semi load buzzing noise to warn you.

alex
06-02-2009, 01:19 PM
ok, i found a buzzer underneath the dash that was disconnected, so i guess thats the one? It's hard to figure everything out when you buy used stuff.