PDA

View Full Version : High Oil Pressure


gomattgo
05-30-2009, 10:56 PM
We just pruchased a 2001 X-9 with 54 hours on it. The oil pressure at idle is 55 psi, and climbs to a maximum of 80 psi with the engine running. I put a manual oil gauge on just to confirm, and it does idle at 55 psi, so I know it isn't the gauges. Is this something I should be concerned with? The manual says it should idle at 5 psi and at 2,000 rpms climb to 40 psi. Any help is greatly apreciated.

Matt

Craig
05-30-2009, 11:25 PM
There are plenty on here that will likely chime in that are far more knowledgeable than I am, but...

I would be far more concerned with 5psi as opposed to 55 or 80psi.

If it pegs your gage while running that may be a problem, way too much pressure and you could blow some seals, that is a major hassle. Maybe your oil level is high?

jixxxer
05-31-2009, 01:00 AM
I noticed on mine when im at almost full throttle or really get on it, the oil pressure jumps up to the 80 range and when i stop or slow down it goes down........???

NatesGr8
06-01-2009, 01:18 PM
i would verify that the oil is at the proper level. are these readings taken when fully warm or while cold?

Nate

rhsprostar
06-01-2009, 10:35 PM
What kind of oil filter is on it? Why I ask is that once i changed to a high quality Amsoil filter my pressure increased significantly. Seems to be fine though. I have a friend with a Bu and has had the same experience with the Amsoil filter.

TX.X-30 fan
06-01-2009, 10:40 PM
At cruising speed mine has always pegged 80psi.

gomattgo
06-02-2009, 11:21 PM
My mechanic said that 60-80 psi won't hurt anything, so I'm going to let it go. I just changed the oil and filter and it's still at 60 psi at idle. Thanks for your replies and help.

PolarBear
06-03-2009, 12:29 AM
My 350 Mag MPI is usually at 40 but does go up to 80 at times. My coworker gear head said the same thing as your mechanic.

454Prostar190
06-03-2009, 11:29 AM
At cruising speed mine has always pegged 80psi.

Same for me

JohnnyB
06-07-2009, 07:03 PM
Same here....worry about it, but when cold (engine temp is 160 but I know oil is not completely hot) mine pegs at 80. Usually after running for a while it backs down a bit.

310 Predator

Chicago190
06-07-2009, 08:23 PM
Mine idles at between 45-55 PSI. Cruising and full throttle the gauge is pegged.

I use the recommended oil and filter. Oil level is in the middle of the operating range.