View Full Version : 2006 X2 Engine cut out completely

12-15-2008, 03:48 AM
Hi, on the the lake on Friday and brought the boat to idle to collect a skier and the engine cut out completely. The motor turns over to start but nothing happens. I have checked the breakers and they seem fine. I have the RTP-1 motor with about 220 hrs.

Interestingly enough, there is another X2 (also 2006) on the same lake that had the same problem on Sunday although he has the 350hp motor. Any ideas?

12-15-2008, 03:53 AM
Check your safety switch? Sometimes those are pretty sensitive.

12-15-2008, 05:46 AM
done that thanks..no joy.

12-15-2008, 07:49 AM
The motor turns over to start but nothing happens

Sounds like you're not getting fuel, next check should be the fuel pump.

12-15-2008, 08:24 AM
Those MasterCraft in-tank fuel pumps are notorious for the symptoms exactly as you describe. Fuel pump would be my bet.

Lot's of threads here on fuel pumps, including at least one tutorial on how to replace it yourself.

12-15-2008, 10:16 AM
thanks - will have a look and get back to you.

12-16-2008, 12:09 AM
I had the same once... bad fuel pump

12-16-2008, 12:28 AM
Happened to me exactly like that this summer on my 05 X-2. It was a dead fuel pump.

12-16-2008, 05:51 AM
Bad fuel pump....thanks for the help.

12-16-2008, 08:13 AM
Bad fuel pump....thanks for the help.

Just a little warning now that you have found it. Never, I say never ever let your fuel get below a 1/4 tank. Prolonged use under a 1/4 tank will burn them up in no time, yes I know it's a sheety design but it is what it is so remember that. Good luck :D