PDA

View Full Version : Shower issues


Ant69
11-27-2008, 05:19 PM
I have just taken delivery of my new X-14. The boat is great so far but I do have one issue and that is with the shower. I can't find any blockages but it pretty hard to get wet with thing. Any comments?

Muttley
11-27-2008, 06:03 PM
It's kind of hard to say, but mine has a "Y" valve with hot & cold spiggots on it under the engine cover. They might be turned off/down.

Does the pump pressurize? Have you checked the nozzle?

Ant69
11-27-2008, 06:25 PM
Checked everthing??Dealer has also??

dsoby
11-27-2008, 07:28 PM
Sounds like a warranty issue to me.

rickmx
11-28-2008, 03:53 AM
I found on my x-14 that the hoses on the back of the temperature contol bend from their own weight and cause a blockage. I used plactic zip ties to hold the three hoses together so they do no bend. You get at them by lifting the plastic box out with the control.

PendO
11-28-2008, 02:10 PM
how does your ballast system function?

If you put it in neutral and run the engine at higher rpms does that change the flow?

Seaworld
11-29-2008, 04:25 PM
I replaced my shower control valve on my 2008 40th and it gave me the pressure I needed. I was not very fond of the new control valve that looked like a kitchen sink fixture. I kept hitting it putting stuff in the trunk and it would change my temp. Anyway ordered the old style from heatercraft, installed it, and no problems. I also shortened any hose that was coiled
up. Hope this helps.

Ant69
11-30-2008, 08:55 PM
I have the sink fixture type control as well and I did also notice kinks in the pipes. As suggested a couple of zip ties holding everthing staight did help.
Ballast works well.