PDA

View Full Version : Water coming out of prop shaft??Help 08 X2


turbosdad
10-22-2008, 10:49 PM
I was washing the boat today in addition to running the motor using a "plunger" type water intake device. When I turned off the water, then the motor, all seemed well. I crawled under the boat to look at the trailer and noticed water that appeared to be "draining" from where the shaft enters the hull.

Is this normal. While I was under there, I noticed a drip rust colored stain running from the shaft hull exit point forward. The reason it went forward was because of the way the boat leans forward when sitting on the trailer in storage. I have never noticed any water of significance in the hull when I pull the center plug after each use.

6 month old boat?????

TMCNo1
10-22-2008, 11:17 PM
Yes that is normal, it's the water from the little line that goes to the dripless shaft log to cool and lubricate it.

dmayer84
10-22-2008, 11:20 PM
It is normal, you have he dripless seal which has a hose running to it to feed it water.

turbosdad
10-22-2008, 11:23 PM
Thanks guys. That is why I come to this board!!! Maybe 3 hours after the incidence and I have the answer.

Again, thanks
Robert

TMCNo1
10-22-2008, 11:23 PM
In the bilge, where the shaft enters the hull you should have something that looks something or just like this with a hose going to it,
41509

Roonie's
10-23-2008, 10:11 AM
It should look like this... mine an 07 X2.

http://i84.photobucket.com/albums/k2/Roonies_2006/DSC_0085.jpg

TMCNo1
10-23-2008, 10:18 AM
It should look like this... mine an 07 X2.

http://i84.photobucket.com/albums/k2/Roonies_2006/DSC_0085.jpg


Looks like it had a full bladder!:rolleyes::D

SkiDog
10-23-2008, 11:43 AM
Looking at that makes me have to pee!