PDA

View Full Version : Ballast impellers-2005 X-star


Jerseydave
10-19-2008, 06:01 PM
Well, after changing all 3 impellers from the black ones to the yellow ones early this season, I was never very impressed with how long it takes to fill/empty my front (KGB) tank.

After running the boat today, I could not get the front tank to empty. Tried switching from fill to empty, pump would run but not pump out any water.

Towed the boat home, removed the yellow impeller for the KGB tank and re-installed my black impeller. Worked fine and now pumps more water than the yellow one ever did.
I think because of the long distance fron KGB tank to pump the yellow impeller just doesn't pull enough vacuum. (plus the hose from the tank goes uphill right at the exit fitting on the tank)

Anyone else have this problem? I think I'll stick with the black impeller for the KGB tank and the yellow ones for the rear tanks.

1boarder
10-19-2008, 08:08 PM
I have heard others say that they lost pumping efficiency with the yellow ones so your results seem reasonable. I think the issue with the black ones is that they sometimes kick off the pump because they were too stiff to reverse. This was solved with larger wires to help the pump in its peak load. I think that the yellow ones take abuse better when people run them dry as well.

prostar205
10-20-2008, 12:24 PM
njskier -

I completely agree with you on your assessment of the yellow impellers. I replaced all 3 of my OEM black impellers with the yellow ones and it took FOREVER to fill and drain my ballast. I went back to the black ones but at the same time polished the insides and cover of each pump housing making it easier for the black ones to go from forward to reverse. They rarely get stuck anymore and if they do, I just toggle between fill and drain and they unstick themselves.

Ben
10-20-2008, 12:51 PM
Where do you buy the spares?

prostar205
10-20-2008, 12:55 PM
Where do you buy the spares?

If you are asking me, I bought them from my local MC dealer.

Jerseydave
10-20-2008, 01:31 PM
njskier -

I completely agree with you on your assessment of the yellow impellers. I replaced all 3 of my OEM black impellers with the yellow ones and it took FOREVER to fill and drain my ballast. I went back to the black ones but at the same time polished the insides and cover of each pump housing making it easier for the black ones to go from forward to reverse. They rarely get stuck anymore and if they do, I just toggle between fill and drain and they unstick themselves.

I may polish the insides of my pumps as well, good idea. What did you polish them with?

Jerseydave
10-20-2008, 01:34 PM
Where do you buy the spares?


Ben, yellow impellers are part # 300218 from your MC dealer.

prostar205
10-20-2008, 04:45 PM
I may polish the insides of my pumps as well, good idea. What did you polish them with?

I polished the inside of the lids on a buffing wheel with some mag wheel polish. For the insides, I used a Dremmel and the same mag wheel polish. The lids came out looking like a bronze mirror.