PDA

View Full Version : Water from speedo lines


scramblerkid
08-12-2004, 07:33 AM
Getting water up my speedo tubes, they worked for a few minutes, then water cam squirting out.

Any clues?

Thanks

BriEOD
08-12-2004, 07:35 AM
Did you check your pickups and see if they're blocked? That happened to me once. Water starting coming out of the gauge (was March, it was cold water!). Come to find out the pitot was blocked and the water was stuck inside.

JimN
08-12-2004, 07:36 AM
Did you blow them out from the front of the lines? If you did and the water is getting into the gauges, the gauges are leaking. I don't know of a way to repair that.

atlps190
08-12-2004, 08:05 AM
Yep...speedo is probably shot. I believe that there is some sort of diaphragm that is supposed to prevent the water from making it all the way to the guage, and when that goes...it's time to find a new one.

-Todd

east tx skier
08-12-2004, 11:00 AM
Did anybody catch that. JimN just said he didn't know of a way to fix something. We're doomed! :D

JimN
08-12-2004, 01:42 PM
ALL IS LOST!!!!!! ALL IS LOST!!!!! :eek3: :eek3: :eek3:

BriEOD
08-12-2004, 01:48 PM
I got my pitot cleaned out and my speedo works fine now. Water came through it... :confused:

scramblerkid
08-14-2004, 11:15 PM
brand new speedos, the lines were a little loose on the back of the speedos, I sealed them with gasket maker, we'll see if that fixes the problem

JimN
08-15-2004, 12:33 AM
They're usually held on with small nylon wire ties. That way, when they need to come off to be cleared during winterization, they go right back on again. They don't need to be very tight, just enough for the ridges on the barbs to seal against the hose.

scramblerkid
08-15-2004, 05:26 PM
gotcha

part of the problem is that the nipple on the speedo is a little bit too small, I have to really cram it on to get it to seal.

I'll try a zip tie on the side I didn't gasket seal.

thanks!