PDA

View Full Version : Red stripe under engine cover, hmmm


boatweight
10-01-2008, 02:19 PM
Last weekend I was doing my year end prep to put my boat (1996 ps190 LT1) in storage, sad day but it's getting cold here in Idaho, and I noticed a red spray stripe on the inside of my engine cover. I am assuming that the transmission fluid is leaking from the drive shaft seal, spraying in a circular pattern when put in gear, but I cannot find any major leak so this might be happening at higher speeds.

Anyone have experience with changing the seal? Is it a big job that should tackled by a mechanic or a handy guy with tools?

thanks for the help. Lee

JLeuck64
10-01-2008, 03:02 PM
I have had the trans apart (and back together successfully for a couple years now!) on my 98 with an LT-1. I did not have to replace the output shaft seal. Good thing, because the nut that holds the flange onto the output shaft of a ZF Hurth is a VERY unique design. That means you would need the VERY special socket to remove it.

If I were you, unbolt the drive shaft and take a look at what I am describing. If yours is the same design as mine you might to consider paying to have the repair done...

boatweight
10-02-2008, 05:38 PM
Good to know, I am going to try and tackle this project next Spring. Thanks for the help

boatweight
05-19-2009, 10:57 AM
Well I finally pulled my boat out of storage and remembred that I still have a leak. I was able to confirm that the leak is happening at the seal, see picture, so from your thread I am assuming this is not an easy fix and it would be wise to have my MC shop give it a look. I do have a friend who is a mechanic and is willing to put some time in for some time on the boat--always a good trade. Any idea what kind of parts and time we are talking about, you also talk about a special socket

Thanks for the help.

ntidsl
05-19-2009, 11:49 AM
I love Red Stripe! Just make you feel like you are in Jamaica!

boatweight
05-20-2009, 11:02 AM
I will make sure that I have plenty of Red Stripe on ice when I try and install the new rear seal. I think I will need it!