PDA

View Full Version : Black from platform leaving marks on seats


bturner2
06-18-2008, 09:57 AM
Is anyone else having problems with the rubber on their fiberglass platform? Whenever anyone gets in the boat from the platform the black from the rubber mat gets on their ffet and leaves foot print all over the interior. does anyone have a solution for this? I was thinking (hoping) maybe there was some kind of sealer I could use on the rubber mat to prevent this.

ShamrockIV
06-18-2008, 10:02 AM
teak will solve that problem!!!

ttu
06-18-2008, 10:06 AM
teak will solve that problem!!!

sham, dang you beat harold to that one.:D

on my first inboard it had the fiberglass platform with the black padding. mine did the same thing.

ended up taking the crap off and replacing with gator grip. never had another issue again.

ShamrockIV
06-18-2008, 10:13 AM
shame to have to modify a new boat!!!!!!

flipper
06-18-2008, 10:31 AM
There are a ton of threads on here about this. It's a known problem. Do a search on it, you'll get all the answers you need.

bigmac
06-18-2008, 10:36 AM
Is anyone else having problems with the rubber on their fiberglass platform? Whenever anyone gets in the boat from the platform the black from the rubber mat gets on their ffet and leaves foot print all over the interior. does anyone have a solution for this? I was thinking (hoping) maybe there was some kind of sealer I could use on the rubber mat to prevent this.

This is an often-discussed problem here. Lot more information here if you do a search.

MasterCraft upgraded the rubber material in 2006. I did that upgrade and found that the problem is less, but not gone - still tracks black stuff to some degree. What I've found is that it appears to be exhaust residue. If I scrub the platform every couple of weeks, it's not an issue. I have a long handled scrub brush, no soap needed, takes about 3 minutes. That maintenance over the course of a year is about 1/10th of the effort necessary to maintain a teak platform. It takes less time and effort than wiping down my sun pad with 303.

So, supposedly (according to John Dorton) the platform material was a problem until 2006. After than, if you're still tracking black stuff, it's most likely exhaust.

bturner2
06-22-2008, 04:50 PM
Fixed it. Bought a teak platfor. Will install over the weekend!

bbymgr
06-22-2008, 04:56 PM
Fixed it. Bought a teak platfor. Will install over the weekend!

Make sure you follow TMC#1's Teak Oil process.